John Lauer Luca Nervetti seeing some odd things with jogging at the moment.

@jlauer @Luca_Nervetti

seeing some odd things with jogging at the moment.

examples:

<Idle|WPos:-0.020,0.000,0.000|Bf:15,128|FS:0,0>
G0X0Y0Z0
[echo: G0X0Y0Z0]
ok
<Idle|WPos:-0.020,0.000,0.000|Bf:15,128|FS:0,0|WCO:0.000,0.000,0.000>

and

<Idle|WPos:-0.020,0.000,0.000|Bf:15,128|FS:0,0>
$J=G91X-0.010F200
[echo: $J=G91X-0.010F200]
ok
<Jog|WPos:-0.032,0.000,0.000|Bf:15,128|FS:0,0>

both suggest that the controller receives a command correctly and acknowledges the receipt (the echo). but then the result move ends up in an incorrect destination.

i think the first one is due to the homing command not taking notice of the current G90/91 state. it should perhaps issue the command G90G0X0Y0Z0. or even better, for grblv1, $J=G90G0X0Z0 so that the G90 is not modal if for whatever reason the person was in G91.

is the second one down to resolution? perhaps grbl cannot resolve to three decimal places? any thoughts?

Is it an inches vs mm issue? Tool offsets issue?

Units was my first thought but everything is set to mm.

Grbl 1.1 tracks tool offset too. Whilst the interface does not deal with it, the coords would still be sent back in the status. Also just for saving of mental anguish the above test was done just after a hard reset ($RST=*) and a changing of reports to be fulsome ($10=2)

The first I think is due to the $H cycle, the second one happens also to me:

<Idle|WPos:-10.879,40.000,0.000|Bf:15,128|F:0|Ov:100,100,100>
$J=G91X0.010F200
<Idle|WPos:-10.869,40.000,0.000|Bf:15,128|F:0> -> 0.010 OK
$J=G91X0.010F200
<Idle|WPos:-10.861,40.000,0.000|Bf:15,128|F:0> -> 0.008 ??

and I think it’s some rounding calculation with the setting values

on the second, I am seeing the same on grbl 0.9 with the new SJPS
ditto on the grbl 0.9 workspace.

build for grbl. and with the official 1.94 SJPS build.

might be rounding errors but is very odd. I don’t remember seeing this a fortnight ago.

On the first point; i think that the $H command is only supported when you have limit switches enabled. I’m fairly convinced that this is just an oversight in the workspace as most people will always be in absolute mode. I will fix in the override section.

By the way, for your overrides there are a couple of new things introduced into grbl 1.1f (published earlier this morning).

it is a steps/mm thing.

by default the steps/mm is 250. so the closest you can get to 0.01mm is 2 or 3 steps = 0.008, 0.012

silly me.