John Hornsby-Hunt   I tried the same 'trick' on few other PCs and every

@John_Hornsby-Hunt I tried the same ‘trick’ on few other PCs and every time it worked for me = the 3d viewer control panel has been loaded properly.

Here is what I did:

  1. Open only one instance of Google Chrome and go to chrome://settings/clearBrowserData
  2. Choose ‘the beginning of time’ from the drop-down list and also ‘Cookies and other site and plugin data’ and ‘Cached images and files’
  3. Click ‘Clear browsing data’
  4. Close Google Chrome and reopen it.
  5. Go to http://chilipeppr.com/grbl or http://chilipeppr.com/grbl-new and optionally hit F5 to reload page.

Please, see screenshot for reference.

Thank you - that did the trick for me!