It's not D9 it's D6 blinking.

gplus
(Ronald DeSantis) #1

It’s not D9 it’s D6 blinking. I tried a master download but it’s not verafied. ?? wish I never bought it. But thanx for the help. Ron

(Ronald DeSantis) #2

I found a master reload on Git hub. Stopped the blinking.

(carl j mcgrath) #3

This is the “official” download site: http://synthetos.github.io/

Does your first post here, “not verified”, what did you do, try again and it worked?

You are very lucky, from your symptoms ( at https://groups.google.com/forum/#!topic/devtinyg/zLGtYYZEeE0) I would not have expected a code download to work, since the bootloader is usually corrupt as well.

What version did you download? Parameter $fv= ?

Good luck!

(Ronald DeSantis) #4

it’s back

(Ronald DeSantis) #5

I sent the board back, for reprograming. got it back got most working. The second bank of wire from power, runs two ports like Y and Z together. So I unhooked that one . Can run a program ,but can’t start a new one. Now what??? I have X Y Z corrected. I just want to start a new program from scratch. Thanx Ron

(carl j mcgrath) #6

I am not real sure what you are asking. Are you asking how to run a new Gcode job(file) ?
Since we are here on the Chilipeppr page, you drag the new Gcode file onto the Gcode widget, it should load into the workspace and be ready to run.

(Ronald DeSantis) #7

I hear you. I had to change the wiring. any way… I got things up and running. I was using Bob Cad to to design but I save the design in TXT , drop it to Cilipepr. It doesn’t run well. Need more suggestions. I used to do CNC on other machines with BobCad but not with this , help

(carl j mcgrath) #8

TinyG only speaks gCode. Does Bobcad save as Gcode?

(Ronald DeSantis) #9

@cmcgrath5035 Yup, Bob Cad is a full program, it does cad and cam . I get g code and save it . when I save it I save as TXT. That the only thing I can get Chili to read. What are my other options. I told you I’m not very good and need help. Thanx

(Ronald DeSantis) #10

@Ronald_DeSantis I tried cnc and ncd.

(carl j mcgrath) #11

@Ronald_DeSantis I have imported gcode files (content is text, a.k.a. ASCII) of the following form: http://file1.nc and file2.gcode. The Widget may load others, I am not sure.

Does your gcode file load into the Chilipeppr widget, i.e. can you browse thru the file and see your gCode? If yes, then something might be wrong with Bobcad settings relative to how tinyG is set up.

Are you able to accurately jog your machine from the Axes widget?

If yes, try locating and running the Chilipeppr logo gCode file, it is well proven.

(Ronald DeSantis) #12

yes I can jog, run Programs but the machine goes wild. I tried settings in BobCad. and inch to MM but I cant come up With the right Z settings. I also tried Touch Off pad. nothing seems to help. BobCad gcodes come in as just lines. I got things screw up I’m afraid. Thanx for the though…

(carl j mcgrath) #13

@Ronald_DeSantis It sounds like tinyG might not be setup correctly.
Create a $$ report in the Serial Port console widget, then copy the results and paste into a text file, put the text file on a cloud drive and give us a URL here
Looking back thru this thread, I cannot determine what sort of machine you have; can you tell us a little about it?

(Ronald DeSantis) #14

it’s a 60 40 I bought on line too play with. I took the control box apart and replaced the boards with the TinyG . I know don’t say it . But I can run project, But they are not to scale. I use MM and the machine goes wild. I can jog. I drag and drop a program , but it comes up just lines and circles. It’s a 4 axis machine with the 4 th axis not connected. Do you still want too help? Thanx. I also tried inch. something in the set up is wrong. I just don’t know what.

(carl j mcgrath) #15

Most efficient way to proceed is to dump your parameters to a file as suggested. Until you have calibrated X,Y and Z and checked with Jogs, running gCode will only frustrate you.
After posting your params, read and reread https://github.com/synthetos/TinyG/wiki/TinyG-Configuration-for-Firmware-Version-0.97 to put my next suggestions in context.

I am aware of 60 40 but not details, start to dig out info on the advertised pitch of your X,Y and Z screws, you will need that.