Issues with getting printer with Smoothieboard running

Hi guys,
ok, i found on the thermistors and the heaters some missed pins which shouldnt be like that.
This is now exactly like it is on the pinout. What i also found is the kill switch, it was set on true and not wired. Means it was theoretically in the kill switch mode with everything on hold.

I corrected it now but i have to go to work, so i will test in the evening today.

1 Like

Hi guys,
unfortunly it wasnt the kill switch.
I really dont know what it is.

Ok, i tried now to get a respond over Network, no respond, over USB no respond.
F… I am not happy.

Can please anybody give me a working config file, that i can see if the board is working?
I have the impression it is not. Just 2 LEDs are blinking and thats it.

Guys forget it, the Smoothieboard meet a hammer head.

Just to be clear: this wasn’t a smoothieboard, it was an MKS v1.3

Could always try Marlin2 on it for comparison to see whether it is configuration or a dead board. There have certainly been reports of occasional DOA MKS boards including in the reprap thread earlier, though I have no reason to think that MKS is necessarily worse in that regard than other board manufacturers.

Hi guys,
yes it was the mks sbase v1.3 board.
Ok i tried now to get marlin v2.0 bugfix version running on it. Without hope it surprisingly worked. I can connect with pronterface to the board. Thats now just the standard config for mks sbase. but for now doesnt matter.

I have a working board (the other one is gone).

I will now try to get the tft running with that and then i am happy like hell.

Using Marlin 2 on that board might be a wise choice.

Last I heard, the MKS v1.3 was a specific target for Marlin 2, whereas @Arthur_Wolf saying that it isn’t fast enough for smoothie makes me think additional frustrations might await even if you got initial functionality working. Although I’m guessing it’s a configuration error somewhere, I don’t run smoothie, and I didn’t find example smoothie configs posted for MKS v1.3 that enabled the second hotend, so you might have been kind of a pioneer there, which can be a frustrating experience.

thank you very much for your help, and also the others here. Thats a great community.

My board is now running on marlin. I have all functions working like they should. Only the Display doesnt communicate with the board, but thats i think just because of the wrong serial port setup. I will find out where the issue is.

At all i am really glad that it works now, because then i can continue with the rest of my printer.


1 Like

Perhaps it doesn’t matter now that you’ve moved to marlin, and perhaps there is some information I’ve missed since i didn’t read the whole thread… but.
In your config you’ve got the following settings which seems way off to me;

default_feed_rate 60000
default_seek_rate 60000
That’s 60000 mm/minute or 1000 mm/s. 1 meter per second. It’s insanely fast. Try something like 5000

alpha_steps_per_mm 152
Strange value but i don’t know your hardware. Have you checked prusas reprap calculator?
Not a big issue though, printer would still work but your distances would be off.

acceleration 15000
Once again an insanely high value. A Prusa i3 or ultimaker has ~1000. A well tuned CoreXY can do 3000-5000 and produce good looking prints. I’d start at 1000 and work my way up if I were you. Try printing a few ripple tests to see what your printer can handle.

junction_deviation 0.01
I’d start with 0.05 which is the default setting in most configs and work your way down from there.

x_axis_max_speed 80000
z_axis_max_speed 20000
Why such high values? I’ve limit my printer to 30000 for X/Y and 600 for Z I can assure you it’s fast enough.

extruder.hotend.default_feed_rate 18000
Once again. Why the high value?

extruder.hotend.acceleration 3000
I’ll eat my sock if your extruder motor can handle that acceleration. Try 100 and work your way upp.

delta_current 1.8
Seems quite high. You sure your stepper motor & driver can handle that?
I run my extruder at 0.5

" # PID configuration" (had to use " " as the hash sign or whatever it’s called makes text bold here)
All your PID values are commented out with a # at the start of the lines. As far as i know PID is required for the hotend to work. But perhaps you’ve got it in your override file?

Your printer looks like a CoreXY to me but you haven’t enabled CoreXY homing;
#corexy_homing false

I’d recommend you go through each line of your config and read up on it on the smoothe wiki.
They also have good starting guides for 3D printers.

There are probably more errors in there. Perhaps the wrong pins are used for example, have no experience with the MKS.

Edit: Spelling

So a TL;DR to my long post
Lower your acceleration by a lot as you’ll probably stall them instantly if you try to move them with the acceleration you’ve got.

Also, please edit your posts and remove “smootheboard” since that’s not the board you’ve got.

Hi Johan,
thanks for your comments.

Yes you are right the values are really high. My target is 1m/s as highest speed.
I also have only on the extruder nema17 motors with 65ncm of tourque.
The rest are closed loop stepper with 3nm of tourque and overload capability.

The corexy is calculated for really high acceleration and also for high force on the head in case something is trying to stop the head. I hate the layer shifts my ender 3 makes, that will not happen at all with this printer.

With the ghosting and so on i will see with the setup of my profiles.

Because the printer is already above 80kg, i wouldnt compare it with a printer which weights under 20kg.


I wouldn’t be surprised if you did manage to get quite high speeds from it, the frame look very sturdy.

As for how high you manage to go frame rigidity is one one part of the puzzle. Having the right motors, as light moving mass as possible, good quality belts and pulleys, good quality rails et.c. is equally important.
If you have a super rigid frame but slack in the rails, belt or motor for whatever reason you’ll still get a lot of ghosting if you go at high speeds/acceleration.

If you looked at my printer you’d probably you’d probably say the 6 mm plywood frame was the limiting factor but I’ve been able to raise my acceleration & speeds quite a lot after switching to Misumi rails, Gates belts & pulleys and Moon steppers without sacrificing print quality.

In any case… good luck with your build.

1 Like

I have just found this thread and have extensive Smoothieware and board experience, if you want to publish your full config file I can check it for you, if you can supply a good photo of the wiring to the board, I can try to verify that too. I have used both Marlin and Smoothie, and I have found Smoothie to be much better :slight_smile:

1 Like

There is no “Smoothieboard 1.3”, what you have is a MKS, this might be of interest to you :

Ok, so far that makes sense. Next board i buy is a original smoothie board not this mks shit. I didnt know about mks that it isnt related to smoothieware.

I am sorry for that.

Anyway currently only the display isnt working which makes me really currious. Because i expected to have a stand a lone controller. Working from SD cards.

Thank you for the information.

The screen is essentially a minimalistic computer, it has it’s own brain and talks to the board over serial ( I’m pretty sure it could talk to a smoothieboard over serial no problem )