Issue with homing

Hi, looking for some help regarding an issue I recently encountered while trying to home my OpenBuilds OX CNC. I’ve run this machine for years using ChiliPeppr with an RPi 3 Model B running SPJS and suddenly, the machine will not complete the homing process. Instead, if I have flushed the queue and set the machine to zero every time it stops and retry, it will move until it arbitrarily stops at specific location: when homing the X, it will stop when the X-Axis readout reads -22.394 inches; when homing the Y, Y-Axis readout is -29.394 inches. Also noteworthy is that that actual distance traveled is not the same (i.e. the X-Axis will move 1/2 inch, and then 3 inches, then 1/4", etc.) but it always stops when that readout is -22.394 inches. It seems to run normally when I feed it some G-Code to air cut.
I’ve tried some of the more basic stuff:
Update the RPi with newest SPJS version
Reflash the TinyG firmware
Change cable connecting RPi to TinyG
Tried multiple browsers
Made sure all wires are secured to the board

Any help is appreciated, thanks

Are you sure it’s not your work coordinate system resetting your Y to that funky value after a homing sequence?

And, btw, this sounds like a TinyG thing, not a ChiliPeppr thing.

Thanks for the quick reply, John. The machine is not completing the homing sequence though. The X-axis will move an inch or two (or more sometimes, its pretty erratic) and will abruptly cease to move. Chilipeppr does not display an error when this happens, it just displays those aforementioned numbers. And it very well could be a TinyG thing but when I instruct the TinyG to home using CoolTerm, it works with no problem. Is there some kind of diagnostics process I can follow to narrow down what this communication breakdown is between TinyG and ChiliPeppr?