Issue with grounding. I guess?!

Hi everyone,
Ran into an issue today with my laser.
It seems to lose ground or have stray electricity somewhere because it keeps losing connection over USB. If I hold on to the case it is fine but as soon as I let go of it it starts connecting and reconnecting on USB. I figured this out by accident :slight_smile:
Check the video, you can see the k40 Whisperer reconnecting and as soon as I put my fingers on the metal hinge it stops. I don’t feel any shocks just not to worry anyone :smiley: Also tried with MeerK40t and its the same
I am not so good with electricity so I don’t know how to measure to troubleshoot but I have checked and I have continuity between the Groung plug and the ground prong in the power cable hole.


I have a problem that the infinitely smart manufacturer riveted a pannel between LPS and the plugs that connect to power and distribute it.

Can anyone help me on the path to troubleshoot the issue?

I have a PSU like this one

I am going to try to run an extension cable to a different outlet just to see if there is a problem with the ground. Nothing has changed in my setup from yesterday to today. Only thing is that I was tilting the machine to get the air out of the tube, but not the first time I done it and it doesn’t lean on any connectors while I do it.

Any hep is appreciated, thanks!

Have you read the K40 Intro at the top of this page? It specifically calls out grounding issues.

I will like it here too:

1 Like

That is where I started, but did not find anythig more than that to check. My ground prong is connected to the shcasy bolt and that is what I could get from there.
I’ll see with a different plug, think that would be the biggest reason

In the US the ground socket of the outlet is connected to the Neutral line in the service box so to test if you have a proper ground at the outlet, we can measure 110VAC from ground socket to Hot socket and 0VAC from ground socket to Neutral socket.

But sounds like USB cable issue if you have chassis grounding functional.

1 Like

Finally figured it out.
So the problem was electricity and even though I checked everything with a multimeter and it was ok, turned out that the inconsistentcy of power was the issue. I have one outlet next to the laser and altho ground was good, phase power was over 240v(I’m in Europe) and I manually grounded the laser from the pin on the case to the outlet it had those random issues. Also checked that the pin is touching the housing and does not have paint in between.
The thing that confused me that it was happening on rastering the most, so I thought it is something with the USB or the board could not handle the amount of data. But the inconsistentcy of power influenced it the most due to high speed and low power it looks like.
I used an extension cable since I don’t have another outlet, and ran it to the laser and it all works now. Not sure why the outlet is bad, but I will replace all the cable running to the outlet and the outlet itself.

Moral of the story, if you have good power and ground but it fluctuates (which I was not able to measure or see on multimeter while running) it will mess with your laser.

I will fix the electricity and get a power stabilizer and that should fix it in the long run not to use the extension cord.

Thanks for the tips!


Sounds like you might have also saved yourself from a possible wiring fire since it seems there’s a loose connection somewhere in that outlet circuit. Loose connections mean higher resistance and that means heat.

1 Like

Yeah, who knows what I will find once I tear it apart