is anyone else having trouble with CP and chrome on a mac?

is anyone else having trouble with CP and chrome on a mac? i’ve not been able to use it for 10 days as it is saying that chrome doesn’t have webgl. which of course it does (and all webgl settings are enabled of course). i’ve reinstalled chrome just in case, but no change.

I guess i need to check what has been updated in the 3d viewer in that time table. It bugs out on if(webGL). Which looks anodyne enough.

No 3D viewer updates have been published in a few months. Can you post a screenshot? I don’t actually put up an error if you don’t have WebGL so wondering where you’re getting that error from and what it looks like.

That is very odd then. I will check when i am at my desk later which 3d viewer my workspace is using.

I’m loading be the viewer from the URL.
http://raw.githubusercontent.com/chilipeppr/widget-3dviewer/master/auto-generated-widget.html

If you check the code it is peppered with error message generation for no webgl. This is the one I’m seeing

http://console.error(‘No WebGL Support found! CRITICAL ERROR!’); http://chilipeppr.publish("/com-chilipeppr-elem-flashmsg/flashmsg", “No WebGL Found!”, “This device/browser does not support WebGL or WebGL has crashed. Chilipeppr needs WebGL to render the 3D View.”, 10 * 1000);

Yes, same issue here, “No WebGL found.”

missing/deleted image from Google+

My guess is that the answer lies somewhere in here: chrome://flags/
I tried the obvious toggles, but got nowhere, same black screen and failure to find webGL.
Someone over on the Inventables forum had a similar problem with Easel and solved it with a flag change to Chrome, but that was back in 2015 and apparently the flag that AngusMcleod references, is no longer in the list. John, maybe if you took a peek at the flags list you might have some thoughts. Here is a link to the Inventables post: https://discuss.inventables.com/t/solved-no-webgl-in-chrome-browser/13139

One additional note is that webGL is working fine in Safari. They have swapped roles I guess.

I find safari is problematic. So have reluctantly installed Firefox for the first time in some years.

I’m lost as to why the problem should be present at all. No conscious changes to my system took place. Simply one day it worked the next it didn’t. I’m wondering whether there may have been an OS update one night.

What model Mac do you have?

2009 mbpro.

I have an early 2011 Macbook Pro and 512 only 512MB are allocated for the Intel HD 3000 video card. I’m down the rabbit hole of forcing my mac to use 1GB for the vid card. I have 16GB RAM. Maybe, maybe, the latest webGL is balking at my old video card driver and/or lack of memory. I’ll let you know when I peak my head back out of the rabbit hole on this.

I think we may be facing the same battle! What’s your video card and how much memory is alloted for it?

Holy smokes, I didn’t fix webGL Chilipepper Chome issue, but I found a video and app that allows you to increase your video memory on our older macs! The person who made the video is not a native English speaker so I’m posting the procedure on another thread and will send a link shortly, since it’s off topic.
missing/deleted image from Google+

I’m still on mountain lion. My machine is not modded apart from an ssd and a second HDD in lieu of dvd drive.
Not sure of how much video memory it has nor what chipset it uses. I can check later.
But webGL is working ok in safari and Firefox. Just not chrome.
I suspect that it is an issue of how chilipepper is detecting the presence of webGL. Although it uses the same code as modernizer uses (not sure why it is not just calling modernizer’s detection method directly) it may be that the latest version of chrome has deprecated those methods. Would be very odd but I’m struggling to think of alternatives. I might try dropping back a couple of chrome versions.

Hmmm, OK, do let us know how you make out. Good luck! I’ll keep banging away on this end as well.

@Justin_Adie i just looked at the code and it’s possible that Chrome changed something such that line 2361 in the 3D Viewer incorrectly fails. Might you be able to try running this from Cloud9 and see if you can just force that line to success and see if everything loads? https://ide.c9.io/chilipeppr/widget-3dviewer

        var webgl = ( function () { try { return !! window.WebGLRenderingContext && !! document.createElement( 'canvas' ).getContext( 'experimental-webgl' ); } catch( e ) { return false; } } )();

        if (webgl) {
            console.log('WebGL Support found!  Success: CP will work optimally on this device!');

            renderer = new THREE.WebGLRenderer({
                antialias: true,
                preserveDrawingBuffer: false,
                alpha: false,
                logarithmicDepthBuffer: false
            });
        } else {
            console.error('No WebGL Support found! CRITICAL ERROR!');
            chilipeppr.publish("/com-chilipeppr-elem-flashmsg/flashmsg", "No WebGL Found!", "This device/browser does not support WebGL or WebGL has crashed. Chilipeppr needs WebGL to render the 3D View.", 10 * 1000);
            $('#' + http://this.id + ' .youhavenowebgl').removeClass("hidden");
            return;
        };

Hi @jlauer

the problem comes in that chrome is failing to get the canvas context. Jumping or forcing the result to true does not fix the problem in that although the error doesn’t pop up, the viewer doesn’t load at all.

i have tried visiting a few other webgl sites on chrome and they appear to work fine. So the issue seems to be with how CP is instantiating/addressing the webgl engine.

actually - more likely the version of three.js is out of date.