In need of help troubleshooting and figuring out if I destroyed my WS2812B strip.

In need of help troubleshooting and figuring out if I destroyed my WS2812B strip. I have tried simple tests with both FastLED and the Neopixel libraries. And I have also tried my arduino UNO and a wemos d1 mini.

I tested the strip a few days ago, and all the leds were working just fine. I have also been able to use the uno and wemos to light up a small 8 led stick.

Is there a way to test if an entire strip is ruined? They are waterproof,ed so it can be a little difficult to see physical damage, but they haven’t really been abused.


The only thing that gives me hope is that I randomly will see flashes of color when first connecting strand to power.

Unless your supply voltage exceeded ratings or suffered a lighting strike, I’d think it unlikely an entire strip would be destroyed. A better explanation as to how/when the failure occurred might help … if it were I my 1st step would be to cut the data trace between chip 1 & 2 and apply data signal direct to chip 2 …

I don’t have any specific events that I believe to have caused the failure. I only have 5v power supplies (I tested both before using). I just thought perhaps I wired things incorrectly while testing that caused the failure. Both micro controllers are still working fine.

Sorry, I know I am being vary vague. Are their any tests I could be doing with a multi meter?

other then confirming power and data at the strip connection point I can’t think of a means …

Another user may be able to give you comparative values for a VCC to gnd … Grd to VCC ohm meter reading … w/ power disconnected … that might provide a indicator of total strip failure … if I’m not mistaken the 2812 provides protection for reversed supply connection so I’m not sure what you could have done to destroy a whole strip … be absolute on all your connections and code …

I agree with David that you should connect the Uno to the second pixel or the third pixel of the strip to see if the first, second or both pixels died.

When I started out with NeoPixel strips (WS2812B), I lost a number of the “first pixels” of the strip (10 out of a strip of 30) until I found out about two resistor protection circuit. You should use the two resistor protection circuit (see and look for ws2812.jpeg) between the Uno data pin and the strip’s data input. Since then and making sure that I am properly grounded, I have not lost a pixel on a strip. Also, the pixels on the strips seem more prone to problems than the pixels on a ring, a stick or a matrix.

Thanks for all the suggestions. I will go and try some things out! Started feeling a bit discouraged.

If I do not find success, I will be sure my next post will follow @Andrew_Tuline suggested format!

Without much luck. Can anyone spot a issue?

LEDs = WS2812B (5m strip, 60/m)
microcontroller = Arduino Uno
FastLED version = 3.1.1
Arduino IDE version = 1.6.10
OS = Windows 10 (64)

circuit = .
I wasn’t positive how to represent the LED strip in fritzing.
DI-data in, VSS-ground, VDD-5v

ino =

I have tested this code on a 8 led stick, and works as expected. I have tried holding the data signal to the next 3 leds further down the strip, but still no blinky red light. I can try going further, but I didn’t want to keep cutting my waterproof casing. I checked the voltage with multi-meter, the 5v and ground appear to be connected properly.

I never had to use a resistor between DI and Gnd. 100 - 500 Ohms in series is fine. Check wheter you get 5V at the end of the strip. Use a fine needle attached to your DI and poke through the insulation and work your way towards the end.
Also press carefully on the LED. I had Strips with bad soldering

It all looks good to me. In my case, since the distance to the LED’s are short, I don’t use any resistors. You could also try a different data pin and different wire.

@Andrew_Tuline do you mean different data pin on my arduino, and a different wire from arduino to data input on led?

Is there a way to detect there is a signal going through the data line?

Yes, try a different pin on the Arduino and try a different wire. Essentially, swap out everything you can. Everything. For instance, just power the whole thing with USB and remove the power supply from the equation.

To detect a signal, you’re best with an Oscilloscope, but a multi-meter should on your data pin should detect a non-zero value.

Thanks for all of the help!!! I haven’t had any luck, but I have learned a few things.

I think I will put this strip off to the side, and adjust my plan to keep my project moving forward. I am going to use a strand of WS2801 instead. Next month when I have more time I will try and get this strip working again.