Improved calibration of my RepRapPro.

Improved calibration of my RepRapPro.
Old printing (black background): huge layers, and the fitting U test ( did not fit at all. 50mm wall was not 50mm in wall width. Measures were not exact (e.g. 52mm instead of 50, and not square)
Current printing (green and yellow bed): Measures are near OK (50mm is 50.4mm or 50.5) Layers are near good. The new U fit test worked fine and I was able to fit a piece in the other almost completely (just about 1mm left).

  • General check and fine alignment of the mechanics (trying to get absolute 90 degree between some axes)
  • Repaired the extruder gear that was shifting (not regular extrusion).
  • Glued the Y-axe plastic pulley (jumped out. Ordered a new one in Aluminium)
  • Tighten the x and y belts
  • Increased the accuracy of the X,Y,E M92 params.
  • DELETED THE SKEINFORGE profile (I played too much with the parameters, and it went out of control) and restore the factory settings coming from RepRapPro, and changed some minor values (e.g. bed centre)
  • Lowered the PLA melting point to 185C

One Z-rods is not perfectly stright and causes some slight move of the X-axe. I will need to find one exactly stright. I tried to fix but it is almost impossible. I looked at a local shop, and they are all bended more or less!
I can’t understand why the 50mm thin wall ( have a 3mm gap at the beginning. It starts do draw the first layer and the plastic stops 3mm before closing the gap. In my opinion it should depend from a wrong Extrusion coefficient (e.g. the plastic ends before it expects) but when I measured the extruded filament length with G1 E100 seemed to extrude 10cm.

  • May be another random shift problem ?
  • Is it the extruder back filament value too hight that should be lowered ? Where is it ?

Another issue is the melting of PLA in short items. The square tower become a half melted cylinder. Even the small parallelepiped on the small circled item in photo is melting down and rotating on itself.
I do not use any fan at the moment.

  • IS IT MANDATORY in the RepRapPro Mendel ?
    If yes, it should be included as base project option like the hot bed is.
    If not, what is the current best approach ?

  • Check the level of belt tight.
    I would need a scientific approach to measure the belt tight.
    My proposal: if I pluck the belt as a string, I get a sound of a certain frequency, that changes as soon as I tighten and loosen the screw.

  • Can any of you that owns a RepRapPro Mendel Mono well calibrated record the sound you obtain by plucking the belt and post the wav/mp3 ?

That would be simple easy to tight the belt until the same sound frequency (and some tight). Of course the recording should be done on the exact same machine model, otherwise other mechanical parameters can change the sound.
Then we could post the file on the Mendel installing Wiki.

Do you have a levelled table where the printer is?
I have make many tests also and I find that my Z axis are not 90° because the table is not correctly levelled and that leads to some half mm gap between layer.
I figure also what you wrote is to use metal pulley.

For thightening the x and y axis are quite difficult for myself. A bit strong and everything can go hell. A bit loose and that’s not accurate.

Good luck. I was very close to throw the printer to the trash can.

I don’t have a precision levelled table. I checked mine with the level and it is more or less good. You can’t have better than a desk at home. The idea of the SOUND FREQUENCY of the belts (that is directly proportional to the tension of the belt) sounds very good to me once the community create the “master samples”. Then you can’t be wrong. Like with the pianos. Nobody tight the piano strings at “more or less” but using sample frequency (diapason in the piano case, a wav file in the RepRap case). I have ordered two new metal pulley (now are in plastic) and a new belt, since I am sure that tightening at “more or less” it will surely break !!
We should find an easy approach that lets everybody to have a fully calibrated RepRap. A lot of people after the initial enthusiasm failed to calibrate the printer and got frustrated, either “dropping the printer in the trash bin” either selling the printer as “never used for lack of space” :(…

@Bruno_Pettorelli The printer doesn’t have to be level to do it’s job. I often pick up my printer and turn it on its side while it’s printing to demonstrate this. The printer does need to be square (all axes are at 90 degrees to each other) and tram (the platform is parallel to the X/Y plane).

I will need to replace the right Z-rod soon. I think it is the main responsible for the visible layers (out of alignment) of the pictures. I can see it oscillate with fast movements.

did you calibrate the stepper drive current?
and set the “Steps per mm” parameters accurately?

The power motor calibration was done by RepRapPro before shipping the kit.
The kit was “ready to use” with the shipped motors.
Also the firmware on the MELZI 2.0 board was a MARLIN 2013.01.10 JMG RepRapPro version “ready to use” and customized.