I'm trying to get Chillipepper working with GRBL.

I’m trying to get Chillipepper working with GRBL. The problem is the visualizer does nothing - that is the tool never shows up, yet I know the GRBL file is being sent to the Nano computer as it hits the 5 holds I programed into the file. I’m using GRBL 1.1f. It must be something simple that I have set up wrong, so far it eludes me. Running Chrome on win 10

I have the same problem with the same settings. Besides not seeing, I can not move the axes through the jog.
missing/deleted image from Google+

The current grbl workspace doesn’t work with the new grbl, you can try using this workspace http://chilipeppr.com/jpadie

Well that link works somewhat better in that it now displays the position in the upper right corner and I believe the 3d sim display is actually working, however the returned position is apparently sent back in mm but is taken as being inches by ChiliPepper and hence the display tool is way off the page and not following the track lines

i tried /jpadie with GRBL 1.1f and the axes data seems to stay at 0 all the time ? What is the max version of GRBL firmware that is supported on /grbl ?

The jpadie workspace is a work in progress but the axes feedback should be fine. I will check later in case a recent commit garbled it.

Justin, in running your workspace with GRBL 1.1f it appeared to me that there was confusion over the units GRBL was reporting. It appeared to me that GRBL was reporting metric and the had it set to inches and the 3d display rendered it that way. However in the numeric display of the position chiliPepper appeared to be taking metric mm from GRBL and just calling them inches, hence the tool was not even on the 3d display. I ran this file several times and on one run it suddenly snapped back the correct inches and put the tool in the picture and milling on the correct line. The file cuts a rectangle in a .09" plastic sheet and does it cutting only 0.02" each time with a hold each time around to clean and cool the bit and the sheet. If there is any other info you need let me know.

i confirm that flashing grbl firmware 0.9j fixes all the problem in /grbl, at least from what i can tell

Thanks @Chuck_Eckert ​. I am back from holiday today so will check.

@Chuck_Eckert ​ can you post your test file? The widget should standardise display and reporting on the units of choice but there may be times where a unit conversion is sent by the gcode (rather than the widget) that the widget won’t know about for potentially up to 250ms.
Anyway - if you can send or post the test file then I will see whether I can emulate the issue you see

How do I get the 12k file to you?

my email is jpadie @ me . com

I tried all this again a few days ago and everything worked so something has been chanced to fix the display and units problem. Now to try out making a real PCB! Thanks Justin!