I'm having trouble connecting to chilipeppr with my tinyg CNC.

I’m having trouble connecting to chilipeppr with my tinyg CNC. I initially connected through my Raspberry Pi 2, but that’s not working so I tried downloading the JSON server on my Linux laptop and connecting directly. It says the JSON server is running, and I see a port pop up on the bottom of the list that seems to be correct. However, even when that port box is checked, it won’t connect. Keeps saying, “Tried to send serial port message, but there is no serial port selected.” Any ideas?

Hi @tlgrimmy ​, could you give us a Screenshot of the full chilipeppr screen please? Perhaps another of the window SPJS is running in?

I would check with ‘ps ax | grep json’ if the process related to sjps is running. If not, you need to start it. You may also add -v switch to sjps to see more detailed information. Finally connect your board, refresh or restart sjps via Chilipeppr sjps widget and you should be good to go.
Raspberry Pi procedure works the same way.

I’ll try to get some screenshots when I’m back home this evening. Later last night, it seems I was able to select the port for the tinyg and messages would send via the JSON server, however, a blue bar appeared next to the port selection indicating the number of tasks or messages waiting to be sent to the CNC. The more I tried to get the CNC to respond by clicking the movement arrows, it just made the blue bar grow, but the CNC never actually responded. Chilipeppr seemed to be running very slowly as well. I don’t really understand much about the JSON server. I just double click the icon and it seems to run in the background. I’ve never seen it open a window or another tab and run. It just seems to be behind the scenes. Sadly, I also don’t understand what you’ve mentioned, Sebastian. I’m not very savvy with this stuff, so I don’t know how to do what you’ve suggested. Thanks again for trying to help me with this. I’ll post again tonight with the pics and any new info.

Here’s a screenshot from Chilipeppr. This time it doesn’t seem to even connect to the port when selected (no blue bar next to port selection after attempting to use the axis arrows).
missing/deleted image from Google+

I just discovered how you can use the URL localhost:8989 to view the SPJS in a browser, so I took a screenshot. I also tried putting “ps ax | grep json” into a command prompt ‘ps ax | grep json.’ Not sure if that’s what Sebastian meant for me to do as I’m not very familiar with all of this. It resulted in the second screenshot below. I’ll keep noodling around to see what I can do and let me know if there’s anything else I should try. Thanks again!
missing/deleted image from Google+

Second screenshot
missing/deleted image from Google+

Hmm. I just released 1.93 yesterday. Can you try upgrading? It’s possible you found a bug in 1.92 based on that screenshot you posted. 1.92 had some features for Cayenn that respond to incoming broadcast messages. It’s possible you have broadcast msgs on your network triggering the replies which chews up CPU on your SPJS machine. https://github.com/chilipeppr/serial-port-json-server/releases

Thanks John! That definitely made things run a lot faster. It still isn’t connecting to the CNC, but chilipeppr loads much quicker and when I select the port, it responds very quickly. I’m getting that same blue bar next to the port with no reponse from the CNC, so I figured I’d take another screen shot of chilipeppr and the SPJS.
missing/deleted image from Google+

SPJS
missing/deleted image from Google+

You should try resetting your TinyG. That’s what I do when I see it not taking in (consuming) commands.

When I get board not responding I do the SPJS restart (red 3rd button in the SPJS widget) followed by TinyG reset button and then refresh SPJS (1st button in the widget) and connect by checking appropriate check box.

The ps ax | grep json on your earlier screenshot shows that serial port json server process is running.

Thanks John and Sebastian. I tried the resetting procedure a few times without any luck, but after opening up the unit and looking at the tinyg, I noticed rust on many of the pins for the stepper motor controller chips. I unplugged it and cleaned everything up with a brass wire brush and tried the reset procedure again when opening chilipeppr. That did the trick! I appreciate all of your guys’ help with this! Nice to have the CNC back up and running.

Happy to hear that it works :slight_smile: