I was using CP in probably the best form it's been in months last

I was using CP in probably the best form it’s been in months last night and this afternoon. About 20 minutes ago it just seems to have totally lost it’s mind (I am in jpadie). I have restarted CP, JSON, and all equipment to no avail. It started by alarming and not letting go even when clicked. I figured something got stupid I started resetting things one by one. Now it’s acting like it’s auto connecting when I restart it but the ‘State’ shows it as offline. I can’t connect.
I am sure that it’s possible that it’s something I have done, but it was just working and alarmed as I was just going to start a job.

Is it possible that there’s work being done on the CP behind the scenes which is causing the oddness?
I will continue to troubleshoot and will call off the hounds if I see something.
Thanks for any help you might have.

I finally got it to reconnect, but the alarms are still coming at a furious pace. How does one go about troubleshooting alarms?

37ed859880c60eef8e89eec902f941bb.png

I would begin in the following way:

  • disable limit switches
  • switch off spindle motor
  • re-check all wiring
  • try basic machine axis moves with manual control
  • run job in the air (make sure to set safe Z height)

All my accidental alarms and machine stops in the past came from electrical noise.

Definitely no work being done by me on the workspace or grbl widget.
Those dont look like alarms either.

NB I have never tested for compliance with 1.1f. I built the widget parser for 1.1e. If there are material differences then they might need explicit catering.

I have had luck all yesterday and today. The last few hours have been a nightmare trying to make things work. Now when I move the readout does not update similar to the issues we were having several months back.

That message in the serial console is a statement that the alarm was triggered at initiation of the session. So a door or limit issue or similar. Follow Sebastian’s advice. If you are getting persistent errors then check the voltage on each of the switch pins to determine what is causing the alarm state.

Also it looks like the controller is either continually being disconnected and reconnected at the sjps level or at the firmware level.

Take the controller out of wherever it is and disconnect from everything. Plug into a serial terminal and see what is coming back. If you’re still getting alarm messages then get a loupe and check the terminals very carefully. If you’ve got a multimeter look for shorts between the switch terminals and ground and between the switch terminals and vcc (depending whether they are active high/low - typically low).

Gut feel is that you’ve got a short circuit somewhere.

Hey Justin, I had replied last night, but I think I left the page without posting it. (???)
I needed to get my project done because my wife was getting home and I couldn’t mess with it any longer.

About a month ago I pretty much finished a complete rewiring of the whole system. While I agree with you about it being a short somewhere, I had put heat shrinking on pretty much everything. I built everything into a box, so I sort of shudder at the idea of pulling everything back out. The only thing that has changed was that I finally wired up the LEDs to my dust shoe (12v). I ran a temporary line until something more permanent could be added. While I doubt that this would be the issue, while I was troubleshooting everything else yesterday, I ran the new line for these LEDs. Afterwards, I was having some issues with CP* which I will mention a little later, but the alarms were not present. I suppose it’s possible that it was something in the temporary run, but… that just doesn’t seem like something that would trip the rest of the system.

The thing that was happening last night and the final straw to move it to UGS was that CP seemed to not be updating when I dropped in a new file. I was cutting out a endmill holder. So a square with a bajillion holes in it. Nothing hard. I had to update the file a few times as I was working as I realized that this or that was not right. So I was about to finish and had successfully milled all the holes. I dropped the file of the contour on CP, the outline showed up and the holes disappeared which I would expect when changing files, but when I ran it, it ran the holes again and stopped with it was finished. It did not do the contour at all. Even though it was on the screen that way. Now, it did shot the indicator doing the holes on the screen, but the lines which you would normally see it gliding on were not present. They were like ghost guidance. The contour op which was present, was ignored. I checked the nc file and sure enough, only 140 lines or so, enough for the contour. Also at the top of the nc file it had in parentheses (cut out) which was my note. So it was like the file flushed the graphic but kept the op which makes no sense. I took the same file into UGS. I ran the file and it cut it out without issue. I don’t know what to tell you man. I am questioning everything right now. CP is my goto and favorite platform for a sender. I love so many things about it. USG while functional has never felt like CP. Plus you can’t start from any given line number. So please don’t take my crazed ravings as a person who dislikes the thing and just wants to complain, I love it, and really need it to work. More, I really appreciate all the time you put into this. I know in my own life it feels like there’s never enough time, so I really do appreciate someone who gives their time to help others out.

How about to undo your last mod and disconnect dust shoe LEDs? Just try to return to last working setup and see if that helps.
Is there a chance that controller board doesn’t get enough power? Do you use same PSU for the controller and other parts of the system?