I synced to the latest 3.1 branch and get the following error on my

fastled-support
gplus
(Zeke Koch) #1

I synced to the latest 3.1 branch and get the following error on my trinket

Two other changes is that I installed 1.5.8 and added the tiny directory to /hardware as they suggest.

In file included from /Users/zekekoch/Google Drive/Arduino/libraries/FastLED/clockless.h:22,
from /Users/zekekoch/Google Drive/Arduino/libraries/FastLED/FastLED.h:33,
from FourPin.ino:6:
/Users/zekekoch/Google Drive/Arduino/libraries/FastLED/clockless_trinket.h: In static member function ‘static void ClocklessController<DATA_PIN, T1, T2, T3, RGB_ORDER, XTRA0, FLIP, WAIT_TIME>::showRGBInternal(PixelController<RGB_ORDER>&)’:
/Users/zekekoch/Google Drive/Arduino/libraries/FastLED/clockless_trinket.h:249: error: ‘TIFR0’ was not declared in this scope

(Daniel Garcia) #2

Ah, I bet the ATTiny doesn’t have the timer bits that I’m using for the interrupt handling. The next thing I need to do is make that disable-able, and will set it to disabled by default for the ATTiny.