I started a thread below with a continuing series of questions that arise as

I started a thread below with a continuing series of questions that arise as I try to get up and running. But, since I am not sure about the ettiquette, or whether anyone is looking at an “old” thread, and since I am stuck, I will ask my latest question in this new thread.

I tried to calibrate my x-axis motor and now it doesn’t work at all. I used the same calibration for the y-axis and that motor works perfectly and is well calibrated.

I suspect that in moving the x-axis motor manually to measure the distance per revolution, I induced a current and damaged the tinyG board. To test that theory, I rewired the x motor to motor 4 on the tinyG and remapped motor 4 from a to x, and remapped motor 1 from x to 1. I set the other parameters of motor 4 to be the same as motor 1 had been (which is also identical to motor 2, but x axis instead of y). X axis still will not jog. I see in the console monitor that it is sending the same code as for a y jog (but x instead), and I see that the tinyG has two red LEDs that light briefly when it receives code. That works for both X and Y. But then 4 green LED’s light on Y jogs but do not light on X jogs.

Any advice? The only other thing I can think to do is to swap two of my motors, but I can’t imagine that I could have damaged the x-motor.

Thoughts please.

Can you post a screenshot of your settings? Easiest way is to screen grab all the tabs in the Config widget (cog wheel icon in tinyg widget) and post multiple pics of each tab. It just seems like a config. I highly doubt manually moving motors burned a chip as I do that all the time for last 2 years.

missing/deleted image from Google+

missing/deleted image from Google+

Here are the motor configurations – is there anything else that might help?
missing/deleted image from Google+

I started to get screen shots of the Axis configurations, which I did not expect to be relevant as I had not changed (or even opened) before. Now I see that X is disabled. I will see if that fixes.

Thanks for your help (and I am sorry to have asked without checking this first, but I tried everything I could think of).
-Rick

I am back in business (and very happy)! Thanks again. My goal is to cut a simple one-sided PCB. I hope to announce my success soon, but won’t be surprised if I have to ask for more help. -Rick

Take video and post it for everyone! We love seeing new projects.

From a quick look, I’ll assume with $_tr=4mm/rev you have a screw machine. I would not worry about damaging tinyG with back EMF from moving your gantry manually; do it slowly. Everyone does it. I’m actually surprised you can move it on a screw machine, but i have no direct experience.

Calibrating an axis movement consists of tweaking the value of $1tr (for x axis, if $1ma=0, mapping motor 1 to X axis) until a requested move of, say 100mm, measures as 100 mm to a degree of precision you are comfortable with.
There is not much tweaking to do with a screw machine, thread pitch is usually well calibrated an uniform. With belt machines, there are a lot of variables.

Diagnosis might go faster if you dump the entire parameter set to a cloud drive a provide a URL.
Enter $$ into the Console, then copy and paste the results to a file and post a URL

What bothers me about your description of results is that even if motor1, assigned to X axis, were defective, I would expect other LEDs to possibly lite up as they energize to hold their position while X moved (assuming all $_pm values =2 ).

Are you sure your X jog was for a move that would be made, e.g. 1.0 mm? A request for a jog of 0.001mm might, or might not, generate a move cycle

Carl – thanks for the suggestions. The problem was that the x-axis motor had become disabled (I can’t imagine how) in the axis page. Fixed now.