I shared this post with Chilipeppr private group and not the community by mistake,

I shared this post with Chilipeppr private group and not the community by mistake, sharing now.

Originally shared by Sebastian Szafran

I finally connected the TinyG v.8 board today and made a first move.
My setup is:

  • CNC 3040 with NC limit switches for X (wired to Xmin), Y (wired to Ymin) and Z (wired to Zmax)
  • switches configured as Homing+Limit on the TinyG
  • NO probe connected to Zmin
  • 120mm 12V PC fan connected to TinyG and continuously cooling the bottom part of the TinyG board
  • current limiting pots set half way (~50%)
  • switches and probe are running 5V and I used optocouplers to conenct them to TinyG
  • Vmot is 30V, I ordered 24V (recommended) power supply on eBay

First tests:
Homing works fine with my NC limit switches, although the cycle is a little different than in TinyG2.
Probing… after my experience with G2, no problems here so far. I used 36 probe points to probe the test job from the picture below with having no issue here.
First job - this simple job contains nine identical elements, a simple pin with two traces 16 mils facing up and 24mils facing down. The only difference is Z-depth, starting Z=-0.02mm down (most left) to Z=-0.1mm (most right) with -0.01 step down. I want to see what milling depth is best for my machine setup.

The problem:
After running the milling job I found the first occurence already fine from the depth point of view (will probably try even a bit higher next time), but there are some issues:

  • elements are placed not exactly as they should be
  • last two elements have some shape issues
  • drill locations are not correct
  • the width of traces should decrease going left to right, as we go deeper with milling, but this is not

Have anyone met similar issues?

Try sending with UniversalGcode server and see if it does the same thing. I’ve noted occasional serial data corruption w/ SPJS. Some of the relative moves get garbled but then a valid absolute move gets picked up and it goes to the correct spot. Also if you are using a Clone Arduino try swapping it out for a real one.

Another other option would be to try without probing and see if perhaps that’s changing the GCODE - I’m doubtful as the render should track that.