I really need some help! With my ramps 1.4 board.

reprap
gplus
(Mano Biletsky (Open MAKER)) #1

I really need some help! With my ramps 1.4 board.

My x axis is not moving. I tried to swap the stepper drivers but that doesn’t make a difference. I also tried swapping the stepper motors. X on the y output and vice versa. Now the x axis does move but the y axis won’t. I checked the wiring of my stepper motors. Those are fine.

So i thought it was a problem with my ramps board. I ordered a new one, and now i have the same problem.

I used the marlin test code (not the marlin firmware).

I am really desperate now.

HEEEEEELP!!!

(Stephanie A) #2

Do you have endstops configured correctly?

(Wylie Hilliard) #3

Since you put the x motor on the y output and it worked, everything outside the board has been eliminated.
The remaining possibilities are an endstop issue (as Stephanie pointed out), pins.h incorrect, microstepper jumpers, bad connector on the board and board failure.
You can check the endstops with M119 (I think) to check the status with the switch pushed and not.

(Mano Biletsky (Open MAKER)) #4

The marlin test code, does not use endstops or anything else. It just moves all steppers back and forth.

I thought it could be the ramps itself. That is why i ordered a new one. But i still have the same problem with the new ramps board.

(Hakan Evirgen) #5

change the cable!

(Gazza3d) #6

Have you tried swapping the stepper motor driver…

(Pudel Fan) #7

Hi. Doesn’t that sound like a broke stepper Motor?

(Ondra H) #8

first check endstop status, if ok, read position, then try to move “damaged” axis and again read position - if position changed, fw believe he is moving with that axis, so other posible problems would be connections, cables, motors (tested) and stepper drivers (on damaged drivers are mostly visible small spot due to heat released that could make you sure)

(Mano Biletsky (Open MAKER)) #9

Allthough i really appreciate your help, most of you haven’t read my post.
I tried everything you suggest allready, and multiple times.

All i can think of is that it is a firmware problem, or both of my mega2560 have a faulty pin?

The x stepper is powered. I can not move it by hand. It just won’t move.

(Ryan Hescock (Stanos)) #10

If you swapped the motors and the issue followed the motor (your words) it’s the motor. You said swapping the x and y motors made the y not work, that my friend is a bad motor or incorrectly wired motor. You could have jacked up the polarity when you connected the pins. Are the motors the same? Are they color coded the same? If they are they should be wired up exactly the same.

Have you tried connecting two completely different motors like what you are using for z axis and extruder?

(Mano Biletsky (Open MAKER)) #11

The issue did not follow the motor. When i plug in the x motor in the y socket, the x motor works.

The motors are working just fine. So are the stepper drivers…

All motors are the same.

Even when in pins.h i change the x pins for the E1 pins (to use the second extruder as X) the motor won’t turn.

Isn’t that a software problem?

(Ryan Hescock (Stanos)) #12

Well if mapping x to the E1 and E1 doesn’t work either I’m at a loss then. You say the x motor runs when connected to y so the motor is fine. You swapped the stepper drivers and the x position still does not produce results so not steppers. I guess next would be to swap x and y in pins.h and see if the problem moves to the originally y position. If it does then there is a problem with the code.

I still think you should load the full marlin and play with it in pronterface.