I purchased the ACR Full kit from all-tek systems about a month ago.( http://www.all-teksystems.com/product-page/162fea05-fb48-56a7-8ec1-38a6200b7fe3

I purchased the ACR Full kit from all-tek systems about a month ago.(http://www.all-teksystems.com/product-page/162fea05-fb48-56a7-8ec1-38a6200b7fe3). I can tell you that Scott Marshall makes a great product! Super nice guy… great support…he helped me do some rewiring over the phone to get my board powered. I had purchased one of the newer K40 machines with the upgraded control board so the power supply was a little different than he was use to.

I am new to all this so please bear with me. When I plug the motor connector into the “Y motor” on the board (See photo) as stated in the directions the motors acted strange. From within laserweb3 when I jogged I could only click the X axis button and the movement was diagonal instead of left and right. So yesterday I plugged the motor connector into the “X motor” connector and now the motors work fine!

The only problem I have now if the laser will not fire in laserweb. When I press the test fire button on the K40 the laser fires. When I run a job in laserweb I see the head move around correctly buy no laser fire.

There are the settings the directions say to put into laserweb. I wonder if moving the connector to X Motor caused an issue:
Gcode Setup Page

Start G-Code

Laser ON Command

Laser OFF Command

PWM Max S Value

Homing Sequence

End G-Code

Travel Moves (mm/s)

Anyone have any ideas until I can get ahold of Scott?

@Carle_Bounds ​ your gcode is wrong

You are using smoothie so first PWM Max Value should be 1

Do you have a analog POT installed?

Also if you are starting LaserWeb as node server-smoothie then you don’t need laser On and Laser Off but for reference in smoothie is G1 (on) G0 (off). Unless @Scott_Marshall ​ has some other magic in his ACR

I had read that PWM Max Value should be set to 1 with Smoothieboards today. Might be a mistake in the documentation… I will try it when I get home. Would PWM set wrong stop the laser from firing?

How is your PWM connected to the LPS?

I’m really not sure how it’s connected. This was purchased as a plug and play solution you just drop in your k40.

Have you ever gotten the laser to fire from the controller (not the test sw)?

Hopefully setting the PWM Max value to 1 will allow the laser to fire in Laserweb. I will try it when I get home.

@Carle_Bounds ​ it should not make a difference but surely setting the wrong On would prevent it

Please post a copy of your config file on google drive so we can check a few things out

@Alex_Krause ​ his film should be the same we looked the other day as its standard on the ACR

No I have never got the laser to for from the controller+Don Kleinschnitz. The laser does fire from the test laser button on the front panel so at least I know the laser works.

I can get the config file when I get home from work.

@Scott_Marshall Tagging you here so you can see if there is anything you know of that will be causing @Carle_Bounds ’ issue.

@Carle_Bounds A thought, since you mention the issue is that when you click X jog buttons it moves diagonally & when you click Y jog it does nothing (?) I wonder is your ribbon cable plugged in the correct way? I believe the ribbon controls the X-axis stepper whilst the plug controls the Y-axis stepper (if I recall correct).

If pwm set to 1 does not work I can try changing the orientation of the ribbon cable. Can changing the direction of the ribbon cable burn anything up? :\

I’m curious if you have the laser module enabled

Here is my config I pulled from the SD card on the smoothieboard:

@Carle_Bounds I can’t guarantee changing ribbon cable direction won’t kill something, so might be best to wait for someone more knowledgeable in that sort of thing to weigh in on it.