I need some help on Bed Levelling with RCBugfix version of Marlin.

3d-faq
3d-qa
3d-help
gplus
(Panayiotis Savva) #1

I need some help on Bed Levelling with RCBugfix version of Marlin.

I’ve enabled auto bed levelling, using the BLTouch.

The levelling routine is fine. Goes to all points and probes fine.

The problem is the Z height.
I tried resetting Z height with G92 Z1, but LCD displays 1 for height, but doesn’t allow me to actually move to zero again.

What setting in the config file do I need to change.

If I only home the printer without auto bed levelling, then Z height is fine. I can adust it using the LCD Z offset.

How do I control this after Auto levelling?

(Panayiotis Savva) #2

Which version of Marlin are you using?

(Ax Smith-Laffin) #3

@Panayiotis_Savva - you need to disable the minimum software endstops:
from
#define min_software_endstops true
to
#define min_software_endstops false

this will allow you to go past 0 and get your offset.