I need help. My PlanetCNC controller imports the files and sets the Z0 at

(George Allen) #1

I need help. My PlanetCNC controller imports the files and sets the Z0 at the bottom of the stock even after I set the surface of my stock as the Z0. I’m not sure if the issue is with the program I imported or with the control software.

(Kyle Kerr) #2

There are 4 or 5 G codes reserved for defining part home positions. I believe they start with G55 and go through G59. It’s been a few years since my classes, so, that is as much assistance as I can be without Google

(George Allen) #3

@Kyle_Kerr Thanks Kyle,

I was figuring it was likely something like that.

(George Allen) #4

I’m thinking that the issue may be changing gcode from either g90/g91 to the other incremental to relative positioning. Does that sound like it could be the problem?

(Kyle Kerr) #5

Incremental is along the lines of telling the machine to home and then x1 followed by x1. That would move with either g0 or g1 from x0 to x1 and then x2.
Relative would require a home then g0 x1 followed by g0 x2.
Neither one of those should affect that.

(George Allen) #6

Yes, that’s what the guy from Meshcam said. Hopefully, I’ll be able to get this corrected pretty soon. I I certainly appreciate your assistance and expertise!

(Kyle Kerr) #7

Lol. Me and expertise in the same positive sentence. :smiley: I do my best to share what information I believe to be true. :slight_smile: It’s even better when the info turns out to help.

(George Allen) #8

Unfortunately, I’m still having issues with my Z and manual tool change. And that’s just a product of not knowing the details of gcode and the general settings of the controller. I’ve had this same current issue with both of my machines. I should know how to correct it, but don’t currently.

(George Allen) #9

It’s destroyed work on several pieces as the spindle either moves into position or tries to return to the home position.

(Kyle Kerr) #10

Maybe a programming course from your local community college or vocational school?

(George Allen) #11


(Paul de Groot) #12

Alternatively you can add an offset to the Z? Just out of curiosity, how do you set the Z zero before you start milling? Just asking these questions so I can better understand how to address this in my own gcode product

(George Allen) #13

Interestingly, I just now attempted to first set the absolute zero position (which is what I seem to have been resetting every time I began to run a program), and then set a different work coordinate system. Somehow I was able to do that, but when I ran the program the spindle went directly to the absolute zero and began running the program.

(Paul de Groot) #14

What if you set the coordinate system to G54 and then zero the Z axis?

(George Allen) #15

I’m not exactly sure how to do that. Do I remove G90 and replace it with G54 or just add G54 into the code after G90? There’s no button or toggle switch on the program that I see for G54. It’s the one I used in Chilipeppr.

(Paul de Groot) #16

@George_Allen This is the sequence of the G-codes from start. G54 comes before G90 …
missing/deleted image from Google+

(Paul de Groot) #17

Try UGS or CNCjs G-Code senders. Each has their quirks but you learn a lot of it and after that you can keep using ChilliPepper.

(George Allen) #18

@Paul_de_Groot I’ll give it a try. I think I see how to do a g54 with this controller in the manual here. Thanks Paul

(Paul de Groot) #19

@George_Allen Google “CNC cook book”, it’s an amazing site that has a huge number of examples how to apply these G-codes. Good luck!

(George Allen) #20

@Paul_de_Groot That’s actually where I purchased Meshcam & it came with their other software (G Wizard Calculator), and maybe the editor too. I mainly bought it for the Meshcam discount.