I just tried to compile the JSON Server 1.93 myself,

I just tried to compile the JSON Server 1.93 myself, even though this was done already, to teach myself the process.

As I executed the “go build” process I got this error in return

“cannot find package “http://golang.org/x/crypto/ssh” in any of:
/usr/local/go/src/http://golang.org/x/crypto/ssh (from $GOROOT)”

I added the GOPATH environment variable - which looks like this. GOPATH=/Users/sesa312639/gosrc

MacOS 10.12.2

take a look here: https://github.com/chilipeppr/serial-port-json-server#how-to-build
it should work by following those steps

@Luca_Nervetti I was compiling the 1.93 version which doesn’t reside at the location described in those instructions, so I download the source zip file and manually copied into a local directory then attempted to build it.

so which version it downloads when u do “go get http://github.com/chilipeppr/serial-port-json-server” ?

when I execute the code that I compile using the instruction i get the following

2017/01/16 18:25:33 main.go:89: Version:1.87

When I look at the version of various files at the location above, they each have different version numbers. so maybe I am compiling correctly but mis interpreting the version number when the code is executed - this is what led me to download the zip file and try to compile locally

first do the command I said, after download the new src and replace the serial-port-json-server directory with the downloaded one. It worked for me

@Luca_Nervetti I checked the version report nothing the json widget in chili pepper and it seems like the the version I got was v1.92. I’ll try again. I’m just a bit confused why the zip file version didn’t compile