I have an Arduino and Grbl Shield running 09 firmware. on a windows laptop.

I have an Arduino and Grbl Shield running 09 firmware. on a windows laptop. and I can not get it to hook up to the system. we tried on my brothers bench computer and it hooked up but never comunicated with the cnc controler. sent codes and tried to jog with chilipepper and nothing.

it works fine with universal gcode sender i am new at this so i need it explaned to me so that and plane old guy can understand.

Joe

Screenshot would help.

this is the best i can do I am not that up to this computer stuff, you have to figure out. I can not even get the server to connect now, to show you what it looks like. On my laptop which i want to use it i can get it to connect now and then, it is running on windows 7 64 bit. i just need to know how to set it up to work or I just continue to use g code sender

Thanks Joe
missing/deleted image from Google+

You need to connect to serial port json server. That IP address looks like a corporate network. If the json server is on your local computer just connect to localhost.

I have tried that and could not get it to connect to grbl shield.

I have been using my brothers email because I could not seem to get signed in to the chilipepper form so here is my email so maybe you can just email me. ( bigguy_63@ymail.com ) does chillipeper work with grbl 0.9 firmware.
is there anything else I can check to se if I can get it running. it does run fine on universal gcode sender.

Joe

Well I finally got in to the forum on my computer. so you can get me here

@Marcel_Deman ​ You need to download, extract and run Serial Port JSON Server - you will find the link in the widget, use appropriate OS version - Windows x64 in your case. Once Arduino is connected and SJPS is running you should be able to see Arduino board on the SJPS list (in the CMD window) - verify serial port number for the board.
Next is to connect to the SJPS from the widget - use localhost (see @jlauer ​ suggestion above) assuming that SJPS is running on the same computer as Chilipeppr. After connecting to SJPS you should see your Arduino board connected to the Serial port you saw earlier in the CMD window. Choose grbl from the drop-down list and check the :ballot_box_with_check: to connect. You should get grbl status messages in the console (bottom left corner) where you can also send commands.

have done all that tried the different builds also

have done that i have gotten it to connect once but could not run the cnc with it and if i typed $$ in the command line i got no return from the grbl. and using the axis to try and jog it around , the window on the left looked like it should move but nothing happened . but that was the only time it worked.

Now can it run in windows 7

What is the status of the machine, ‘Ready’ or ‘Alarm’?

@Marcel_Deman ​ I’ll be back home in ~3hrs from now and can take a look via Teamviewer, if you want. We can chat on Hangouts - just let me know.

Sebastian Szafran I am not going to be by the machine for a couple of days. I am up in northern AZ .
As for the status of the the Arduino/grbl it is offline , even when it did look like it was connected. When it showed that my com port was communicating wth the Arduino.
Now if I try to hook to the json server with out the Arduino attached, should it still connect to chilipepper. I have tried on three computers and none of the connect. But if it will work I will have the laptop with me up north, that is the one I want to use anyway.
Let me ask you this which version of json should I be using? My Grbl is using .09 firmware.
And I do not know what hangout are, I am kind of New to this. google comunity , like just yesterday.

@Marcel_Deman ​ I’ve just sent you a message on Hangouts (you will find the application on Google Play or Apple Store or use simply a browser.
Let’s talk later, when you’re available. I’m CET (GMT+2), which is 6 hours later, than New York time, but we will find the way if needed. I already helped few folks in the US.

@sszafran I just installed hangouts on my phone. still not sure how it works I did not see the message you said you sent.
one thing I can tel you that when i go into chilipepper my json server says disconnected and when i try to connect by pressing connect to server it usually says failed to connect.

Ok one question. if I load the json on the laptop and run it and get the message that says json server is now running. then i go to chilipepper and start it in grbl. when it loads should I see that it is connected to the json server even if the arduino is not connected. or does the arduino with the grbl shield have to be plug in for it to work. I will be back near my cnc plotter Tuesday afternoon.

but one thing i can say the one time it did connect to the arduino it said it was offline.

@Marcel_Deman ​ You surely have to connect Arduino with grbl firmware burnt into it in order to make it work.

I would do it in the following order:

  • connect Arduino
  • run SJPS (you should see CMD window with some lines of text including your Arduino board and the serial port number, it is connected to)
  • start http://chilipeppr.com/grbl workspace
  • connect chilipeppr instance to SJPS server in the SJPS widget (bottom right corner of the screen) by checking appropriate checkbox next to Arduino on the devices connected list, remember to choose grbl from the drop-down list before clicking the check :ballot_box_with_check:
  • once connected you should see some status lines in the console (bottom left corner of the screen)

In case the device State shows ‘Alarm’ in the GRBL widget, type $X in the console followed by Enter key. The grbl Alarm flag is being automatically set after first time connection to the device in order to make sure the operator will react (home the machine) before operation. $X clears that alarm.

I hope this helps.
http://chilipeppr.com

Sebastian
Hi that helped i am conected to my arduino and grbl but for some reason it tells me I am offline in the grbl work space and it does nothing.
https://profiles.google.com/photos/106644906351773883084/albums/6337773332863960609/6337773332379756930

@sszafran
Thanks for the help . I did finally get it running. I found out that I was closing the JSON server because I was closing the cmd window after I ran it. But I also had to change it to 9600 buad rate it defaulted to 115200 and it would not go online it always said it was offline. I went back to my universal gcode sender and it would not run on 115200 either so that is how i found that out. so thanks for al the help.

@Marcel_Deman It looks like your board is running grbl 0.8 flavor where default speed is 9600. You may compile grbl 0.9 available on github: https://github.com/grbl/grbl/wiki/Compiling-Grbl and flash it onto your board. I recommend that you read the documentation first, as there is pin change: limit Z and variable PWM are swapped, more details here: https://github.com/grbl/grbl/wiki/Connecting-Grbl