I have a tinyg controller and am using chillipeppr.

I have a tinyg controller and am using chillipeppr. Yesterday I used the cnc router with no problem. Today I can’t run a program. All my settings are the same as the day before. The jason port is correct but nothing is working. I did have a notice about too many files in my local files so I eliminated most of those files so that notice isn’t showing up anymore. I’m at a loss as to what to do next.

Reset TinyG and re-check that appropriate :ballot_box_with_check: is checked, sometimes Serial Port JSON Server restart might also help.

Did you delete them from the browser drop down?

Thanks for responding. I have pushed the reset button on the tinyg and made sure everything was checked off in the right box. I deleted the files from my documents not through the chillippr site. When I check the file through chillippr it shows them gone. I notice on the serial port console that the information about the machine settings such as speed and travel, etc., are not showing. I’ve loaded other files and get the same result.

There is a drop down next to the widgets drop down and you can erase them from there. They all get stored in the actual browser and that’s where them need to get erased from.

When I open the gcode file in that it goes to my documents where I stored my files. I only have 2 cnc files in there. If chillipeppr has stored all my cnc files I am not sure where they would be or how to open them.

Weird, I had the same problem but when I could use the erase recent files from that tab it would go away. I think it stores them in a temp folder in chrome or something.

There is a little trashcan icon under the list of recent files

The trash can removes the past files. I’ve reinstalled chrome, eliminated all my gcodes from my files and it still won’t work. Can’t think of what to do next. It’s probable something simple. Can anyone help me out?

First of all recheck your wiring and all connections.
Run SPJS with -v switch (verbose output) and make sure your TinyG COM port is listed there.
Connect to this COM port with terminal program and try few simple commands to check the communication e.g. $, $$, $m or G0X10, G0Y10 etc.
Once this step is OK, disconnect terminal session and connect via Chilipeppr. Repeat communication tests from Chilipeppr console.
Watch SPJS window for detailed output (verbose mode).

Thanks for responding, is it possible to explain all that in more detail as I am ignorant is all this sort of thing. I really have not idea what you have just told me, sorry.
Would you mind emailing me with the information? belljn@hotmail.com
Thanks

Can you post a screen shot? My gut says this has nothing to do with recent files list.

I’ve changed the ubs cable and in looking at another video I added $$ in the bottom space of the serial port console and no change. I guess I’ve got a communication problem. When plugged in the red light flashes continuously. I’ve tried the reset button on the tinyg also.
missing/deleted image from Google+

Just reflash firmware and it’ll likely fix your problem of red lights flashing.

Can you post a screenshot of the SPJS window just after you start it (with board connected), so we can see what is the serial port number assigned to TinyG?

Hope this is what you need.
missing/deleted image from Google+

I reflashed the firmware and the red light stopped flashing but showed a failure.
missing/deleted image from Google+