I have a Makerbot Replicator 2 and my last three print attempts seem to

I have a Makerbot Replicator 2 and my last three print attempts seem to be shifting a couple hours in. Any ideas?

I don’t know if it is a mechanical issue getting hung up and causing it to pick up printing a 1/4" off track… Or if it is just a software glitch.

Anyone seen this before?




You must make a RepRap printer.

This is probably from the motor/driver on what looks like your X-axis.
If the gain on the driver is just a bit too high, it will slowly overheat until it skips steps. Or maybe the heatsink on the driver has loosened. That’s my best guess, but make sure your belt pullies are tight, if they weren’t i think the print would look much worse but doesn’t hurt to check.

Is your belt slipping?

Fantastic advice… but how do I check or change the driver gain? Or how can I test the heatsink? I did try to tighten the pullies, but it was very hard to turn and I didn’t want to strip the bolt.

with Rep2 not being opensource i cant find the specifics but there should be a small trimpot on the electronics near the driver for each stepper. I’m assuming there is a heatsink but it’s not necessarily the case. If so just press it hard against the chip it’s mounted to. If I knew what the circuit boards on Rep2 looked like I could be a bit more help.

Have you tried cleaning and oiling the rods? That solved this problem for me on my ToM.

Do you have already the extruder upgrade installed? Otherwise you have a lot of information on this channel http://www.youtube.com/feed/UCKnR1qd86QsvZO4mTwieFmA

@scott_maher There are no trimpots, the voltage reference is set digitally, and the values are stored in Eeprom (change them from MakerWare’s onboard settings). There are also no heatsinks on the drivers, as they do not tend to get hot in even long operation.
@Inspired_Ideas , do you know if the speed or or acceleration values have been changed for this particular print? Does it fail in the same place each time?

This is likely a known problem with the X-axis cables on the Replicator 2 – there is either a short or an open with the cable, causing the steppers to not operate correctly. http://toybuilderlabs.com/blog/2013/4/24/replicator-2-x-axis-jitters

I have seen shifting caused from a loose pulley. My prints were shifting in the Y direction and when I tightened the Y pulley, that solved the problem.

@Benjamin_Rockhold , I have never messed with the speed settings and the prints were not failing in the same place each time.

@Chris_Horton , I tightened the X-Pulley and it initially seemed to work great. I was able to print a quick 15 minute test perfectly and made it over 10 hours on my real print before it failed.

However, now I can’t even move in the X-direction at all. It just makes a loud clicking sound when I try to Jog in the X-diection.

Thanks for the link @Joseph_Chiu … I think that may lead me to the solution.

@Inspired_Ideas I still think you need to tweak the motor gain. When you tightened the belt you added friction. The clicking is the is the motor trying to step but not having enough power. I’m guessing the axis is shaking a bit while it clicks, and the motor is likely hot to the touch. loosen the belt just a bit to reduce the friction, and turn the voltage to the motor DOWN just a bit, so that it wont overheat after running for a long time. @Benjamin_Rockhold mentions that you can adjust the motor voltage from the firmware, but I couldn’t find it in the docs.

Note that in my case, I only had to tighten the screw holding the pulley to the motor shaft, and not the belt. If you did both, then maybe there’s too much friction, per @scott_maher . Another possibility is that the motor shaft hasn’t been flatted, or if it has, you tightened it but not on the flatted side (so after 10 hours it started sliding again).

With the machine off, if you try to manually move the carriage, does it move easily and smoothly (compare against the y axis)? If not, then there is a mechanical issue. If it seems to move okay, then the cabling or the power setting is more likely the culprit.

Thanks for all the great advice everyone! I just installed a new XYZ Cable that MakerBot sent me for free and it works perfect again!!