I hadn't used my mostly stock K40 (I only modified the bed) in about

I hadn’t used my mostly stock K40 (I only modified the bed) in about a month or so, and when I turned it on yesterday, my (always on) Windows 7 PC didn’t even recognize it. I has been sitting with the same cable connected to the always on PC the whole time. I tried plugging the USB cable into a known good port (my OpenBuilds Ox CNC was on it) and it still didn’t recognize it. When I tried to reinstall the Zadag drivers and when I selected List All Devices the CH341 didn’t pop up. I have yet to try a different cable, but I don’t see how the cable would suddenly fail (I’m still going to try it). I leave all switches off including the e-stop when it is not in use, so if the cable is not the cause then I’m going to be really stumped. :frowning:

Check power to the board. You might have lost your power supply or just at that connection.

The whole system seems to power up (I see the control panel stuff all come on). I’d need to open the electronics cover to check–does the stock board have indicator lights?

The controller board does not have any indicator lights

@James_Rivera I got the same problem. Connected it to a new computer and it worked then…

I find that my system will change my controller to ramps unexpectedly. Even with ch340 drivers still installed. I need to go into divide settings and disable ramps and change it to the ch340 under com ports.

I tried to troubleshoot it today and it just…worked. WTF? Ok, nevermind.