I got my k40 laser about a year and half ago,

I got my k40 laser about a year and half ago, installed the smoothieboard and firmware and had it working just fine. Now, it seems things have changed and I am completely out of of the loop with the laserweb group. I got started with laserweb3, and had it running great, but never had time to make the laserweb4 transition. Could someone point me to a guide (or give some suggestions) on what to do to get back into using the laser? It’s an all stock k40, only upgraded the smoothieboard.

The last time I gave it a shot it seemed like laserweb4 was working on my computer, but I was not able to make the machine move. I’m sure this is due to firmware, or not connecting correctly. I would really appreciate some assistance. Alex Krause got me going way back, and I greatly appreciate all his help, but I am having some difficulty getting back into it.

I’m not cnc illiterate or anything, I have a few 3d printers and a couple different cnc machines, but for some reason the laser seems baffling to me. Thanks for any assistance.

@Mark_Leino I suggest you start by getting the latest version of LW4 and choosing smoothie from the default machine profile in settings and report back.

I have some basic videos on YT on how to make operations in LW

@Ariel_Yahni_UniKpty thanks buddy. Will do.

dude you should check out Lightburn. It is awesome you will never look back!

Bit rude for me @Tech_Bravo_Tech_Brav

@Mark_Leino it is different if you use smoothie or grbl-lpc firmware.

Ok, got home from work and downloaded the latest laserweb version. It recognized my usb port (even though it had a strange name) it connected, and said machine connected. I then changed to generic smoothie machine, and went and tried to home the machine, no movement. Tried to jog, no movement (and I made sure that the jogging disabled was set so I could jog). Any ideas for next steps?@Ariel_Yahni_UniKpty

What firmware are you running in that board?

I’ll check. What do I need to be running?

So I pulled the sd card, put it in the computer, and I open the firmware and it’s just garbled up info. Tried note pad, and gedit. Probably just need to update to a new firmware

Ok, so i updated my firmware. Put it in the machine. Nothing. Went back to computer, realized I have no config file on the card-only the firmware. I also think I’m going to rewire to the 2-wire schematic. Any other suggestions?

@Ariel_Yahni_UniKpty Sorry for being smoothie unsavy, but where can I find a config file for a k40?

@Mark_Leino I suggest you ask in the K40 forum as im not using smoothie anymore. Or maybe @donkjr could help here?


I found this, how/what file type do I save it as?

Post this in: https://plus.google.com/communities/111870450664099533727

for your best answer.

Pretty sure my SMOOTHIEWARE config and firmware file are:


First things first.

  • What Smoothieboard do you have? C3d-Mini?
  • Firmware should be CNC flavor
  • Make sure the electrics are properly setup. Having connected USB will light up the board logic (up to 5 green leds), but maybe you have the motor power disconnected (red leds)
  • Another check. Download Arduino IDE, setup and connect to your board with correct baud speed. go to console set up linefeed \r\n and type $H. If does not do something (like homing) you will be better get support on Smoothie / k40 group

Thank you. @Jorge_Robles I got into it and forgot about that forum. I have the board ordered directly from smoothie. The firmware I pulled just from the github page, didn’t use the cnc flavor so I will get that. I copied the config file into gedit and saved as text file, then copied to sd card. I will check my wiring (or change) and report back. Thanks again.