I forked the tinyg workspace into GitHub then opened my fork in Cloud 9.

I forked the tinyg workspace into GitHub then opened my fork in Cloud 9. When I ran runme.js, I got a message saying that --debug was deprecated, then the process exited. After a lot of false starts, I got it working by clicking on the green icon that looks sort of like an insect, thus turning of debugging, and re-running the runme.js script.

Apparently the default Runner: Node.js script is out of date. I wonder where that script lives?

I right-click to Run and then I click on the URL where it says “Your code is running at https://workspace-tinyg-chilipeppr.c9users.io.” in the bottom console window to open the webpage that runme.js dishes up.
missing/deleted image from Google+

Yeah, that’s exactly what I did. But the bottom console window said this:

Your code is running at https://simpletinyg-mitchbradley.c9users.io.
Important: use process.env.PORT as the port and process.env.IP as the host in your scripts!

(node:10492) [DEP0062] DeprecationWarning: node --debug and node --debug-brk are invalid. Please use node --inspect or node --inspect-brk instead.

Process exited with code: 9

Only after clicking off the debug flag would the process run correctly

missing/deleted image from Google+

This did not happen to me the last time I used Cloud 9 to edit the 3dviewer widget.

this happens to me too. in new instances, not older ones.

perhaps the node.js implementation is bust.

if there is no quick fix for this I may rewrite runme.js to use some more standard server app like php.

wasn’t thinking straight. c9 is just a manager for vms. the node virtual machine had been ugraded in the standard vm build. that’s the issue.

so the solution is trivial.

open a terminal (right click on the tree, select open terminal)

type the following commands

nvm install 4.6.1
nvm alias default 4.6.1

that’s it. the scripts will now work.

if you get an error then you may have to kill some stalled processes. or stop/start the workspace at worst.

@Mitch_Bradley tag.

Yep, that fixed it. As an old-school software developer dating back to days when C was the new kid on the block, I am continually amazed by the number of disparate tools it takes to do modern development.

Anyway, thanks for the fix.

We all secretly long for the days of zx80s @Mitch_Bradley

This issue just bit me. Thanks for the tip. I had to lookup this post to figure it out.