i can't connect to Chilipepper . it states it's disconnected.

gplus
(Ronald DeSantis) #1

i can’t connect to Chilipepper . it states it’s disconnected. any ideas would help?
I’m new to chilipepper.

(JOHN LAUER) #2

Screenshots can always help all of us debug your issue.

(Sebastian) #3

You have to run a Serial Port JSON Server and connect compatible controller to the host where SPJS is running. Next connect to the right IP in Chilipeppr SPJS Widget, click on the checkbox left to your controller board and you should be good to go. A screenshot will definitely help.

(Ronald DeSantis) #4

ok I ran json, got every thing working like move ment of machine, but can’t open cnc program I drag and drop. Thanx for the other help com ments. I used BobCad to generate g code. Ron

(Ronald DeSantis) #5

Ok got past that now I screwed up something that turned on blinking red lite D9. Locked it up . Also do have Blue light . I don’t know how to screen shot . Ron DeSantis

(Sebastian) #6

Are you on Arduino Uno and /grbl workspacr or TinyG or ArduinoDue (g2) and /tinyg workspace?

(Ronald DeSantis) #7

tinyg

(Ronald DeSantis) #8

@Ronald_DeSantis chiilipeppr, tinyg

(Ronald DeSantis) #9

I kept messing around but now I have D9 blinking and every thing is locked up. I tried reset button ,not that, reprograming board, not that. I think it is locked up trying to send info. How would I clear that? Holy cow ! Bat Man

(Ronald DeSantis) #10

D6 not D9 sorry, I sent a request to Synthetoes, Thjanx

(Sebastian) #11

More details is needed in order to try to help you. Do you have limit switches installed and connected to the TinyG board?
Is it NO or NC limit switch configuration?
What is the limit switch action type configured (limit only/homing only/limit+homing/none)?
Is your machine properly grounded?

Debugging actions:
0. Check ALL connections.

  1. Temporarily disable alarm actions in software (if enabled), run a job and see result.
  2. Disconnect limit switches, run a job and see result.
  3. Disconnect stepper motors, run a job and see result (TinyG is only connected to the PC via USB port and you will see job running on the screen.
  4. If you have extra stepper motors available, connect it to TinyG and run a job. Motors will rotate 'in the air.

Make sure you set adequate safe Z-height, so you don’t plunge into material or into machine bed. No tool is needed in a spindle for testing.

It is possible that your problem might be related to electrical noise. In such situation common behaviour is that machine stops in a middle of a job randomly with no reason, or it stops immediately after spindle start or spindle stop, or when other electric device is powered on.

(Ronald DeSantis) #12

@sszafran I sent the board back and asked to have it reprogrammed. I’'ll see if that comes back. Thanx Ron

(Sebastian) #13

I hope this will solve the issue. Nevertheless I will be happy to help you, if needed.

(Ronald DeSantis) #14

THanx