I am successfully using ChiliPeppr to jog my X-Carve CNC,

I am successfully using ChiliPeppr to jog my X-Carve CNC, but when running pasted gcode it pauses after 10 lines. The code keeps buffering, but the machine will not move more unless I click Cycle Start “~”. Even then it will only execute one line before pausing again. Any thoughts on what might be the problem?
Otherwise I am pleased with the features ChiliPeppr offers and am working on customizing my workspace!


What version of spjs? Grbl or TinyG? Full screenshots help

Sorry, forgot to add those details… spjs v1.86 and GRBLv0.9j

Full screenshot: https://goo.gl/photos/FLZew3uQHZoydTo36

I tried a few scripts and it always stops after the first several lines.

It appears that your Grbl device is frozen. Have you issued a reset? Grbl loves to put itself into an alarm state. When I look at your stats it appears you’ve filled up your 128 bytes that are allowed to be sent. Grbl sends an OK when it has processed a line. I’m not seeing any “OK” coming back. That indicates it’s in an alarm state. However, I’m seeing “idle” in the Grbl widget so that makes it feel frozen. What if you just reset everything especially the Arduino Uno?

That makes sense, but is weird that it is not saying “alarm state” as I have seen before with other issues. Totally new to this though, so that doesn’t mean it isn’t obvious to someone more experienced! I reset the Arduino and that helped some; I made it through 21 lines this time. Screenshot: https://goo.gl/photos/Ujt1LZ8k9wKD3Z1F9

Oh, and I have been doing soft resets in between scripts just to be safe.

Hmm. I’m still not seeing any “ok” responses come back per your screenshot. Your GRBL device is just plain not sending data back. Could you possibly try SPJS 1.83 just as a test case? 1.83 uses a different serial library that may work better/different on Linux and I see you are on Linux.

Hi Jarret, yes the serial comms problem was resolved in the latest release. The serial comms problem was introduced by moving to the serial library that the Arduino team added to SPJS for their new upcoming web IDE. I thought it was solid, but it turned out to have packet loss. So, I moved back to the original library I had used all along and the problems have gone away.

Ok, so my guess is that 0.9j is introducing a new problem as 1.86 does nothing different for the Grbl buffer.

Appreciate your input gentlemen! So which version of GRBL should I try since it sounds like SPJS 1.86 should be okay?

GRBL 0.9i indeed works, thank you! I was able to run a job to completion. A couple days later it was stopping mid-job again - Using verbose output I saw that alarms were being triggered, and it turned out to be an electrical interference issue with the limit switches. I rerouted my spindle power cord away from the limit switch wiring and further isolated them. Since then I have not any more stopped jobs!

Yes, that sounds much better! Even in verbose mode it took me a while to see the alarm notifications… they were not highlighted in any way and were cut off by the size of the widget.