I am new to 3D printing - have just built my first printer -

3d-faq
3d-qa
3d-help
gplus
(Mike Le'Daero) #1

I am new to 3D printing - have just built my first printer - a Prusa i3.

I have calibrated it to a few decimal places and done a few test prints - a 10x10x10 cube measured 9.93mm on my digital callipers.

But, for my first ‘real’ print, I seem to be having a problem and I’m not sure which area it lies:

When I print (using PLA), my print starts out fine, but as it continues, the print head drags on the print, eventually hitting it hard enough to miss steps and thus, screw up.

As it seems to get progressively worse, is it more likely to be calibration or have I got my steps per mm too far out (they are within a couple of decimal points - so 100mm = 99.25mm)?

(jenia zelikman) #2

This might be due to warpage and bad adhesion to the surface.

(Mike Le'Daero) #3

No warping, adhesion is solid - the object is firmly bedded to the surface - I’m not so new that I wouldn’t have noticed the object moving towards the head. What’s happening is that the head is dragging through already extruded lines.

I suspect that I need to refine my z-axis even more.

(DongWon Han (DWONH)) #4

I’m guessing you’re having trouble when printing model that has multi area in layer, If so, it might be caused by over extrude or excessive blobs from inadequate retraction.
I had same issue before.

(Björn Ringholm) #5

To me it sounds like you need more cooling of the part being printed.

(Step Cia) #6

My guess would be bed warp. On my i3 while leveling the bed, I can get the bed to level at 4 corner near the screws but as I move the nozzle manually toward the middle in the x direction, the nozzle actually dip down and touch the glass even tough at the end of the x direction the nozzle would return back to same level where it starts at the other end…

This tells me that I have a bed warping issue and I’m trying to solve this by changinge the 4 screw location to 3 screw location holding the bed. Will do so tonight.

(Mike Le'Daero) #7

Current State: recalibrated everything to within .02mm over 100mm travel (is that close enough? It’s better than the ‘purchased’ units I have measured - like Makerbot Replicator)

Checked and zeroed bed - as close as I can get it to level, I believe. It didn’t need any adjustment from before - it was fine.

Rechecked filament and Slic3r settings - changed to .3mm layers as it is a better divisor with my stepper settings.

Restarted my print - after three layers, noticeable dragging across the existing print - enough to visually see the bed deflecting and audible dragging noise. I cancelled at that stage.

After changing the layer setting, there is noticeable ‘lumpiness’ to the top of the print - before it was quite smooth - even in the infill areas (40% infill).

Buggered if I know… I guess I go back to scratch and check/calibrate everything again - for about the 5th time…

I must be doing something very wrong… it feels like it is something very basic, not some esoteric, weird setting…

(Mike Le'Daero) #8

@Bjorn_Ringholm I am unsure how part cooling can make the nozzle drag through the existing layers. Can you explain how that would affect the nozzle height?

(Mike Le'Daero) #9

@Brigham_Valdez I’ve rechecked the stepper current - it’s fine. The steppers themselves and their heatsinks don’t get overly hot - I’m using DRV8825s, but have only set for a maximum of 1A. The steppers aren’t missing steps, until the nozzle hits the print.

I have just recalibrated all axes - the Z-axis when told to move 100mm, measured movement of 10.02mm (digital calliper).

Is that close enough or do I need to get it even closer? My calliper varies by .01mm or so, just pulling it from the axis…

(Mike Le'Daero) #10

I just went through the specs and compared my settings with the ‘factory’ settings. And I am confused.

I have 8mm leadscrews holding up the Z axis - according to spec, they progress 8mm for every 360 deg rotation. I am using DRV8825 drivers set to 1/32 stepping, with 200 step/rotation steppers…so…

Each 8mm takes 6400 steps (200 steps x 1:32 micro steps) ergo each mm of travel takes 800 steps. But… my Marlin settings are for 784 steps/mm.

This would seem to be the problem, except… when I tell the printer to move 100mm at 784 steps/mm, it moves 100.02mm - if I had it set to 800 steps/mm, it would move 102.04mm - even though logic would dictate that an 8mm leadscrew should move 8mm per rotation.

What am I missing/doing wrong here?

I guess I should set the Z-axis to 800 and see if the problem goes away… but it still doesn’t answer why it measures different to how it should - could my stepper/driver settings be out of whack?

(Mike Le'Daero) #11

Thanks - I think I am losing my mind here.

I cannot work out why an 8mm leadscrew is giving a measured 784 instead of 800 for the steps/mm - I think I need to go back to basics.

But - you might have hit on something with the z-axis power - I will check.

I suspect it is as simple as the steps/mm setting on the z-axis, though. If the axis isn’t moving up as high as it should, it would be ok for the first couple of layers, then progressively get worse - it would also explain why the top layer is getting ‘lumpy’. I will change to 800 and check the power setting.

Thanks again.

(Aria C Bramanta) #12

I assume you use 2560-ramps 1.4 with stepsticks, I encounter the same problems and input 1066 - 1400 on the step, works fine and increments good via pronterface move manually 10mm/1cm (and it did move manually 1cm), all the way to 180mm/18cm, I did however encounter the exact same problems on my friends prusa, and resolve it with zero-ing my z jerk (zjerk = 0), and works perfect, this problem was resolved on the rep rap forums (note : some ramps manufacturer are custom boards), just use the M92 code : M92 Z1066.67 (or whatever value works) saves you the trouble of keep uploading firmware to the arduino

(Mike Le'Daero) #13

@Aria_C_Bramanta I am using Marlin 1.0.2 stable. The rod is 8mm threaded.

The printer is a SunHoKey Prusa i3 - they have sold shedloads of them… but I do seem to be like the Titanic of making things break.

The original setting for Marlin were: M92 X80.50 Y80.50 Z405.60 E80.50

I am using DRV8825s, not the A4988s the unit shipped with (because I had them and they are better than the ones shipped) - I kept the jumper settings, so the resolution went from 1:16 to 1:32. With that in mind, the configuration should be M92 X161 Y161 Z811.2 E161

But those settings don’t give accurate dimensions. When measured, my settings were: M92 X161 Y161 Z784 E965 (I am using a different, geared extruder - again, because I had one and it’s a better unit - a BondTech).

(Mike Le'Daero) #14

@Aria_C_Bramanta That’s very helpful about the Z-jerk. I will definitely give it a try.

Yes, I am using M92 - I am intimately familiar with it :slight_smile:

I am new to 3D printing, but not motion control. I have 3 or 4 RAMPS boards, a couple of TinyG and a couple of Smoothieboards.

I will also look at Pronterface… Repetier is ok, but not my favourite app.

(Aria C Bramanta) #15

Your welcome glad I could help, happy printing…and let me know if it works out for you

(Peter Hertel) #16

How is your filament diameter set up? I moved a 3mm config to a 1.75mm hotend and forgot to change diameter, that was fun. :sweat_smile:Sounds more like a e step issue. Have you tried to use z hop?

(Mike Le'Daero) #17

Z hop?

The filament is fine - measured at multiple points to an average of 1.7mm.

I agree, it seems more and more like a step issue - but not the e-step. it’s extruding fine.

I’m pretty sure it’s the Z-axis config. I will go with plain vanilla 800steps/mm and see what happens.

Tomorrow - it’s late, and I’m in bed.

(Peter Hertel) #18

Yes, but did you set the correct diameter in slic3r? Z hop/lift moves the z up on retract moves, to avoid it hitting the print.

(Mike Le'Daero) #19

Yes, the filament was right in Slic3r.

It looks like the problem was a combination of z axis and extrusion setting - not enough z movement and too much filament.

Thanks to all that put forward ideas.

Got some nice test prints , now to do some real work!

(Mike Le'Daero) #20

LOL. Is that what they say? :slight_smile: I must have skipped that part on the YouSoStupid Guide