I am having an issue where my nodeMCU 0.9 ESP-12 Module is randomly pulsing

fastled-support
gplus
(Gibbedy G) #1

I am having an issue where my nodeMCU 0.9 ESP-12 Module is randomly pulsing unused leds in my string of ws2811 lights.

See the video for an example where this happens on the nodeMCU and the same code on an arduino nano (using same hardware otherwise) does not show this issue.

#define FASTLED_ALLOW_INTERRUPTS 0… fixes the issue but this causes pubsubclient/mqtt to stop working in my real program.

I’m using fastLED 3.1.6.

Am I doing anything wrong by using pin D3 (GPIO 0) on the nodeMCU.

This is my first attempt at using fastled with the esp8266.
Thanks.

(Jeremy Spencer) #2

Try using pins IO12, IO13, IO14 or IO15 (D5, D6, D7 or D8 on a D1 Mini), I seem to remember having issues with D3 (IO0).

(Gibbedy G) #3

@BK_Hobby retry count reduced the pulsing of leds while allowing mqtt to work, but has not fixed it completely. I’m not sure it can be a hardware thing as I know it works when I don’t allow interrupts. I will check but I believe the nano I’m using, like the nodemcu, that are feeding my first booster ws2811 on the circuit board are 3.3v. I’ll try using other output pins next, the theory being that something is interrupting gpio0, but I would expect someone here would say if this was a known issue.

(Gibbedy G) #4

Same on other pins. I’ll try a level shifter

(Brian Lewis) #5

In your setup routine you should also set the WiFi to not sleep. That plus setting the retry count to 0 has always fixed the flickering issues for me.

(Gibbedy G) #6

Hmm. That sounds promising. 74hct245 didn’t work. @Brian_Lewis

(Brian Lewis) #7

WiFi.setSleepMode(WIFI_NONE_SLEEP);

(Gibbedy G) #8

Retry count to 0 is enough for my fastled only test to have zero random pulsing. Disabling wifi sleep on my real program using pubsubclient reduced the pulsing to about 1 per second. I’m guessing using pubsubclient is blocking/interrupting my fastled.show. Thanks for the help everyone. I might try a mysensors setup to see if it is compatible with fastled.

(варешяф рйезот) #9

I have same issue till I add capacitor to led strip.
And one more interesting thing (sorry for pore English) - I see, that my round spiral matrix of 100 ws2811 at the center is not white, but a litle orange. And all leds are flickering.
Troubles gone after I add capacitor between leds “+” and “ground”. After that - I add good power source and troubles gone ).
Also, you can try this hack for ESP (for level “balance”): https://hackaday.com/2017/01/20/cheating-at-5v-ws2812-control-to-use-a-3-3v-data-line/