I am having an issue using ChiliPeppr and a TinyG.

gplus
(Ted Ellison) #1

I am having an issue using ChiliPeppr and a TinyG. Before all this was happening I completed quite a few projects. All of the gcode files that I have tested exhibit the same symptom.

Seems to be related to flow control but I am not sure.

When I run a gcode file, the ChiliPeppr file for example. I get 8 or 10 lines of gcode executed and then everything pauses, A resume command executes one more line of gcode and back to pause.

I have checked my serial port settings, several times and also the settings on the TinyG. Must be missing something.

Any help would be appreciated. Very frustrating.

Thanks,

Ted

(JOHN LAUER) #2

Are you sure you have the correct buffer planner selected in the serial port widget before you connect to TinyG in the serial port? That buffer is super important. Also, what computer are you running SPJS from? Your local machine or a Raspi?

(Ted Ellison) #3

John, I see you all over this site and you really seem to be the go-to guy. Thanks for responding. When I posted, I was afraid I didn’t provide enough detail.

I have a home built OX driven by a Tinyg, with the Goode being delivered they chilipeppr thru the SPJS, both running on my windows 10 laptop.

As I was looking thru other posts, I saw your comment about chilipeppr needing to be in json mode when communicating with tinyg. I tried changing the ej setting from 0 to 1, however each time I look at the settiing ($sys) it is set to 0. Thinking that I may need to reflash the tinyg I tried to get a configuration listing that I could save first. I find that sometimes I get a lot of “???” Before I get a list and the list is incomplete.

I know everyone says this, but all was working well the last time I fired this puppy up. Really seems to be some stupid setting that I have missed.

Do I need to send a reset to tinyg after changing a setting? Turn it off/on?

Long post, thanks for your time.

On a completely different topic, I was listening to the Kim Komando radio program yesterday and she was mentioning some alternatives to Google+ and I believe she posted that info on her website. Might find an alternative for the group.

Thanks again,

Ted

(JOHN LAUER) #4

Well, when you first connect to your TinyG from ChiliPeppr, a bunch of commands are sent that put your TinyG into the correct mode, so you should be ok as being in JSON mode, but if you really want to verify you should turn off the filter/funnel icon in the console window to see all the commands coming back from SPJS. If they are JSON format then you’re good to go. However, only being able to process a few lines of Gcode does feel like a JSON/Text mode problem potentially. Could you post some screenshots of some your whole screen but including some serial port commands in the console window after you’ve jogged and with the filter/funnel turned off?

(Ted Ellison) #5

Thanks John. It will be a test of my posting skill. Will do.

(Ted Ellison) #6

John, Life is not fair. Today i got on the system and practiced doing a couple screen grabs so I could send them to you.

Next I fired up the SPJS and started cool term. I noticed that the default baud rate was 9600, so I went into the device manager and changed it to 115,200. When i tried to connect, coolterm gave me a 103 connection error. I went back to device manager and reset the com port to defaults including 9,600 baud. I again opened coolterm and selected my saved configuration for tinyg - 115,200 baud etc.
worked fine. While I was in coolterm I decided to look at the tinyg configuration with $sys and all looked fine (ej is set to 0, text). So now I used $$ to look at the complete configuration, it came up with no problems so I saved it to a text file, just for luck. Closed cool term and opened ChiliPeppr.

Connected to the com port and took a screenshot. Started the ChiliPeppr logo job so could take the next screenshot when it stopped. Well, it ran to completion with no problems. So now I ran my new job and it also ran to completion (both in air mode).

So here I am eating crow. I have no idea what is different between now and yesterday, but at the moment all systems are go and I consider the issue closed and offer my deepest apologies for taking your time.

Ted

(JOHN LAUER) #7

No worries.