homing

smoothie-forum
(skywalkerF34_SW) #1

I didn’t find the way to make my CNC homing correctly on endstop : the home seem to be the power On position
I have a 600*900 cartesian CNC, some EndStop have problem so I disable them before changing later
M119 command give me a 1 on the right EndStop when I test manually

Here is my config :

endstops_enable true # The endstop module is enabled by default and can be disabled here
corexy_homing true # Set to true if homing on a hbot or corexy
alpha_min_endstop 1.24^ # Pin to read min endstop, add a ! to invert if endstop is NO connected to ground
alpha_max_endstop NC # 1.25^ # Pin to read max endstop, uncomment this and comment the above if using max endstops
alpha_homing_direction home_to_min # Or set to home_to_max and set alpha_max and uncomment the alpha_max_endstop
alpha_min 0 # This gets loaded as the current position after homing when home_to_min is set
alpha_max 600 # This gets loaded as the current position after homing when home_to_max is set
beta_min_endstop 1.26^ # Pin to read min endstop, add a ! to invert if endstop is NO connected to ground
beta_max_endstop 1.27^ # Pin to read max endstop, uncomment this and comment the above if using max endstops
beta_homing_direction home_to_min # Or set to home_to_max and set alpha_max and uncomment the alpha_max_endstop
beta_min 0 # This gets loaded as the current position after homing when home_to_min is set
beta_max 900 # This gets loaded as the current position after homing when home_to_max is set
gamma_min_endstop NC #1.28^ # Pin to read min endstop, add a ! to invert if endstop is NO connected to ground
gamma_max_endstop 1.29^ # Pin to read max endstop, uncomment this and comment the above if using max endstops
gamma_homing_direction home_to_min # Or set to home_to_max and set alpha_max and uncomment the alpha_max_endstop
gamma_min 0 # This gets loaded as the current position after homing when home_to_min is set
gamma_max 100 # This gets loaded as the current position after homing when home_to_max is set

alpha_max_travel 600 # Max travel in mm for alpha/X axis when homing
beta_max_travel 900 # Max travel in mm for beta/Y axis when homing
gamma_max_travel 200 # Max travel in mm for gamma/Z axis when homing

  1. Optional enable limit switches, actions will stop if any enabled limit switch is triggered

#alpha_limit_enable false # Set to true to enable X min and max limit switches
#beta_limit_enable false # Set to true to enable Y min and max limit switches
#gamma_limit_enable false # Set to true to enable Z min and max limit switches

  1. Endstops home at their fast feedrate first, then once the endstop is found they home again at their slow feedrate for accuracy

alpha_fast_homing_rate_mm_s 10 # Alpha/X fast homing feedrate in mm/second
alpha_slow_homing_rate_mm_s 5 # Alpha/X slow homing feedrate in mm/second
beta_fast_homing_rate_mm_s 10 # Beta/Y fast homing feedrate in mm/second
beta_slow_homing_rate_mm_s 5 # Beta/Y slow homing feedrate in mm/second
gamma_fast_homing_rate_mm_s 2 # Gamma/Z fast homing feedrate in mm/second
gamma_slow_homing_rate_mm_s 1 # Gamma/Z slow homing feedrate in mm/second

alpha_homing_retract_mm 5 # Distance to retract from the endstop after it is hit for alpha/X
beta_homing_retract_mm 5 # Distance to retract from the endstop after it is hit for beta/Y
gamma_homing_retract_mm 1 # Distance to retract from the endstop after it is hit for gamma/Z

  1. Optional enable limit switches, actions will stop if any enabled limit switch is triggered (all are set for delta)

#alpha_limit_enable false # Set to true to enable X min and max limit switches
#beta_limit_enable false # Set to true to enable Y min and max limit switches
#gamma_limit_enable false # Set to true to enable Z min and max limit switches

  1. Optional order in which axis will home, default is they all home at the same time,
  2. If this is set it will force each axis to home one at a time in the specified order

homing_order XY # X axis followed by Y then Z last
move_to_origin_after_home true # Move XY to 0,0 after homing
endstop_debounce_count 100 # Uncomment if you get noise on your endstops, default is 100
endstop_debounce_ms 1 # Uncomment if you get noise on your endstops, default is 1 millisecond debounce
#home_z_first true # Uncomment and set to true to home the Z first, otherwise Z homes after XY

  1. End of endstop config

of course the machine can move manually on every axis :wink:

Any suggestion ?

Rgds

Imported from wikidot

(makegeneve_SW) #2

This line looks wrong:

corexy_homing true # Set to true if homing on a hbot or corexy

If it’s a cartesian CNC this should be false.