Homing trouble [solved] LaserWeb4 + GRBL 1.1. Home switches at back right.

gplus
(Blue Transistor) #1

Homing trouble [solved]

LaserWeb4 + GRBL 1.1.
Home switches at back right. Switches are normally open and pull the inputs low (to ground) when reached.
X and Y jog functions are working correctly.

Pressing the home button fails to generate any motion but gives the following messages:

  • ALARM: 9 - Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.
  • Firmware grbl 1.1g detected
  • [MSG:’$H’|’$X’ to unlock]

Relevant GRBL settings are
$10=3 // Status report.
$20=0 // Soft limits disabled.
$21=0 // Hard limits disabled.
$22=1 // Homing cycle enabled.
$23=0 // Homing cycle direction.
$24=25.000 // Homing low speed.
$25=500.000 // Homing high speed.
$26=250 // Homing debounce.
$27=1.000 // Homing pull-off.
$130=1000.000 // 1000 mm X
$131=600.000 // 600 mm Y
$132=200.000 // Z not used

Any ideas?

(Claudio Prezzi) #2

Did you try to invert the limit pins by $5=1?

(Blue Transistor) #3

Thanks, Claudio.
No. As explained the switches are verified to have correct polarity.

It turns out I have to disable Z-axis homing (and the line beneath it) in config.h and enable simultaneous X & Y homing.

I’ve just got it working.

Now to set the laser PWM frequency …

(Claudio Prezzi) #4

By the way: $10 should be 0 for LaserWeb!
A value of 3 is not anymore valid since Grbl 1.0.