hi, need some help,info on where to connect the limit switch .

hi, need some help,info on where to connect the limit switch . i have a novusum 200hz usb cnc mach3 controller and on the manual say something about connect a limit to a 1`2v and input 3, now where the rest go does say anything the manual ???
attach image
can’t find any diagram how to connect to a ox cnc ???

The answer is…
Wait for it…
It Depends!

Mach3 can be configured to have any input as any function, in the Config/Ports and Pins/Input Signals menu. It can be as simple as wiring all of your limit switches in parallel to one input, or you can wire each limit switch individually to it’s own input, and anything in between.

This burns up a lot of inputs, though, especially if you want to have separate Homing switches. The usual convention is to use one input for each axis, and wire all the switches for that axis in parallel. The machine doesn’t need to know which switch was triggered, and you can see which one it is just by looking at the machine.

Homing is taken care of by which direction you specify the machine to move toward the homing switch, it doesn’t need to be a separate switch.

It looks like your box has a bunch of inputs in the lower right, just pick 3 and change the Mach3 settings to match. It looks like the inputs are active high and tied to + 12 by the switch to activate, but it should say in your manual. If you have trouble figuring out which input is which, use the Mach3 Diagnostics screen.

Hint: If you wire up all the switches on an axis in series instead of parallel and make them all normally closed, the loop will be closed all the time and have much better noise immunity. Just reverse the polarity in the Mach 3 Input Signals menu.


Thank you. For the input.

Pun intended? :slight_smile:

Your Limit switche(es) will connect between 12v and the Input (#) you want. Across the bottom of the controller there is a section Marked INPUT PORT. Whichever you connect to, you will need to enable that in your Controller software (Mach3 or whatever)

Do I use the normal open " No " limit switch or "NC ".
One more think I just plug all the motor to the step driver and the controller,
One steper driver, A axis in my case show only the red led and the rest have red and green on can’t figure out why…

@Mike_Gallo You can use either NO or NC, just configure Mach3 to be either normal or inverted input. I recommend using normally closed, it has better noise immunity.

Possible one of your stepper drivers is bad, or a wiring error. Also, check switch settings. Check to make sure you have 5V on the common terminals of all the drivers. Also, check controller config to make sure you have A Axis enabled. You don’t really need it, you can just parallel the A and Y axis driver inputs together and feed them both from the Y axis outputs of the controller.


thank you Mr Darrel ,i will check it. i tested the board with a laptop and so far they motor moves the wrong direction of the arrow key and the Z axis too.

@Mike_Gallo To reverse direction on a stepper motor simply swap one pair of winding wires. IE, if the motor has one winding red/green, and one winding yellow/blue, simply reverse either the r/g or y/b wires (not both) where they connect to the driver.

You can also invert the motor direction output in Mach 3 to accomplish the same thing.


Thank you, got the right direction and calibrate the axis .now when the limit switch hit , I get stock on emergency. I am talking on the z axis , really short run. I have a ± limit connected. On mach3 I have -+ and home pin on. The z axis won’t move till I move manually back away from the limit switch trigger with the power off.

@Mike_Gallo Hey Mike:

I’m having a hard time with your english, but I think I got the gist of it.
Go to the settings tab (ALT-6) and click Auto Limit Override in the Special Functions box on the left of the screen. This should allow you to jog away from the limit switch after you hit it.


Ok , thank you.