Hi, I'm using grbl 1.1f on my Arduino Uno based CNC,

Hi,

I’m using grbl 1.1f on my Arduino Uno based CNC, along with ChiliPeppr in Chrome.

However, when I connect to the COM port of my Arduino (successfuly - I can issue grbl commands and jog the axes), I get NaN mm for the X, Y and Z axes (prior to connecting these values are 0 mm. To demonstrate this, please look at the top right i.e. the Axis widget in the following image:

Search the ChiliPeppr Google+ forum for a bunch of discussions on this.

Hi John, thanks for the swift reply. I didn’t realise the forum existed, I assumed this was the place for help.

I’ve just been across and searched for my issue “NaN” and have only found 3 threads, none of which are to do with my issue. Is there any chance you could provide a link to one of the relevant threads please?

NaN stands for ‘not-a-number’. Make sure that your serial port is set to ‘grbl’ and not ‘default’, which I think is default setting after you launch /grbl workspace or any other setting (drop-down list in the Serial Port JSON Server next to your ArduinoUno board).

Thanks Sebastian for the reply, I have my serial port set to grbl.

On another note I have a weird issue with the auto level function. I set my z axis to a point just above the PCB and then run the auto level, it descends till it touches the PCB and the alarm goes off as it should. But then it seems to hang there instead of move up and to the next probe position. I don’t know if these two issues could relate to the same underlying problem, but either way I need to discover the cause.

You have to use this workspace: https://chilipeppr.com/jpadie, because default workspace is out of date to use with GRBL1.1.

http://chilipeppr.com/jpadie

Thanks, you were completely right, it fixed both of my issues :slight_smile:

Thanks for the tip @Camilo_A_C ​​​. I am not regularly using /grbl since I installed TinyG on my 3040, but occasionally I will be able to make a use of the grbl 1.1 flavor.

EDIT:
This must be the workspace @Justin_Adie ​​ is working on. Good job, Justin. Keep on…

Sure. How can I to get the sorce code from these workspace to work on it?

Is /grbl out of date again? Tell me what to pull in…

/jpadie works goodfor GRBL 1.0 and beyond. GRBL 1.0 had some big changes.

@raykholo
The workspace is a work in progress. Not suitable for a pull request yet. Particularly since the fixes and enhancements span a number of widgets and the workspace itself.

Major to dos on the widget include:

  • Improve the settings management functionality
  • Harmonise the coordinates by forcing the renderer/axes/grbl widget and board to use the units specified by the gcode.

The workspace contains the fix for the autoleveller. But i am also working on enhancing that to provide for greater granularity in the resultant gcode. I will probably do that through the workspace overloading too as I’m not convinced that this is something that everyone would want.