Hi i'm trying to upload code to a funduino board and getting this error:

fastled-support
gplus
(MrZeedie) #1

Hi i’m trying to upload code to a funduino board and getting this error:
In file included from C:\Users\Col\Documents\Arduino\libraries\FastLED/pixeltypes.h:5:0,
from C:\Users\Col\Documents\Arduino\libraries\FastLED/chipsets.h:4,
from C:\Users\Col\Documents\Arduino Sketches\thundercloud\thundercloud.ino:2:
C:\Users\Col\Documents\Arduino\libraries\FastLED/lib8tion.h:2:2: error: #error WTH? led_sysdefs needs to be included first
#error WTH? led_sysdefs needs to be included first
i’m a bit of a novice at this so any help would be appreciated.

(Daniel Garcia) #2

What version of the Arduino software are you using and what does the code that you’re trying to build look like?

(MrZeedie) #3

The Arduino software is 1.6.7 and the code can be found here:


Thanks for the reply.

(Daniel Garcia) #4

I haven’t had a chance to test with 1.6.7 yet - but what that error most likely means is that it isnt able to determine what platform you’re building for - either that or the Arduino folks broke the build system even more in 1.6.7 than it was in 1.6.5

(MrZeedie) #5

So any ideas of a fix? Remember i’m a novice at this!

(Daniel Garcia) #6

Unfortunately all I can suggest for the moment is grabbing Arduino 1.6.5 or 1.6.6 and trying with that. I’m about to spend the entire day traveling internationally and won’t be able to try testing what’s going on myself for at least another 8-12 hours.

(MrZeedie) #7

Ok thanks. So you I guess you think its an issue between FastLED and the Arduino software version? Please let me know if you narrow it down. In the meantime i’ll try as you suggest and let you know the result.

(Daniel Garcia) #8

The Arduino folks have been making changes to their build system that break some of the things that we do. I suspect I’ll have a few more tickets to file with them tomorrow.

(MrZeedie) #9

V 1.6.6 produced the same error.

(Daniel Garcia) #10

Have you added anything to the .ino file that you linked to? Because that error makes it sound like you have put #include “chipsets.h” right into your ino file.

(MrZeedie) #11

It would appear that v 1.6.5 has compiled and uploaded correctly subject to some testing.

(MrZeedie) #12

I have not modified the code at all.

(Daniel Garcia) #13

Are you downloading your version of arduino from http://arduino.org or arduino.cc? (I only test against the version from arduino.cc - and 1.6.6 from arduino.cc has no problems compiling thundercloud.ino - what board are you selecting under Tools | Board?)

(MrZeedie) #14

Arduino.cc and used “Arduino/Genuino Arduino”. Is it better to use a different option for the Funduino? It’s not listed in the board types.

(Daniel Garcia) #15

Weird - then I have no idea why you are seeing the problem that you are with 1.6.6. The network connection in Mexico is pretty terrible and I haven’t been able to download 1.6.7 yet to see what it is doing.

(Daniel Garcia) #16

Ah - did you by any chance go into the menu and select “Sketch | Include Library | FastLED” ? – because it looks like when you do that, recent versions of arduino will include every header file in FastLED, instead of just including FastLED.h – which causes the error that you were seeing above. I just checked in a fix for the library to deal with that particular bit of insanity in the arduino IDE.

(MrZeedie) #17

Yes I did notice the addition of all those extra headers when including the library on the newer software versions. I think you’ve identified the problem.

(Daniel Garcia) #18

Grab the most recent version of the library - I’ve put in fixes to protect against this.

(MrZeedie) #19

Great, thanks for your help.