Hi, I use chilipeppr for all my jobs in my eshapoko with my surface


I use chilipeppr for all my jobs in my eshapoko with my surface pro, i want to know if its possible to use an raspberry PI with ubuntu connected to my Arduino and remotly in my surface pro connecting to raspberry by WiFi and see the chillippepr server webpage i have in rapsberry?the same question using a webcam conected in the raspberry.


Yes, that should be possible.

OK thanks John i will order an raspberry for my next upgrade in my shapeoko:)

I recommend a faster device now like a Beagle Bone Black, Intel Edison, Odroid, or Hummingboard.

OK, and with the beaglebone i can connect them to grbl with chilipeppr?using ubuntu por another so?

i can use network cable conection because i have a router close my shapeoko:)the beagle bone seems very intersting, i can also use a little monitor:)without doubt is my next upgrade:)

I’m using a RaspberryPi with SPJS and it seems to work fine.

Gents, just a heads up that the near future will demand a bit more
specificity in posting - grbl runs on an Arduino Ono, soon tinyG2 software that runs on an Arduino Due will be more available, While both are “Arduino”, Due is much different hardware than Uno, is 3.3V logic and communicates via a native USB implementation, not an (ftdi correction, my error, Uno has a custom programmed microcontroller front end doing USB to serial conversion, not ftdi device) add-on chip.
tinyG2 software also runs on tinyGv9 hardware, available for experimentation on John’s new Cloud platform.

Its grbl in arduino, but its in my plan upgrade to a tinyg but its difficult to buy in europe:(

Carlos - Read up on tinyG2 over at Synthetos. If you are other wise happy with you machine and gShield drivers, your could potentially swap out your Uno for a Due, load tinyG2 and be ahead of most all of us!
Caution: unclear when a Master of tinyG2 will appear, still some issues being worked. Here is a starting point: https://github.com/synthetos/g2/wiki

I have the Arduino due flashed with an old version of tinyg2 ( edge branch) but i cant send any position to my motor, i dont know if i can upload the last version of tinyg2, i have to check this weekend.

Just to say thank you for the advice, i receveid the beagle bone black yesterday, flashed with debian and running Serial Port JSON Server, i already tested and it works fine:) now i have to check if i can send serial comands and connect my bbb to my arduino uno via rx/tx pin and use a joystick connected in my bbb to jog my cnc…do think it can be done?

@Carlos_Tavares ​ for your joystick why not just go direct to the gpio of the bbb. Skip the arduino. Use @Ben_Delarre ​ gpio server

i’m actually working on a jog dial box for ChilliPeppr server that will jog the machine. It’s coming along well so far. And it will run on the Pi / BBB and talk to SPJS directly.

I found an instructable to comunicate with my uno using a logic level shifter, it can be done easily but i take a look in John option using gpio server, i will go to try it tonight.

i´m trying to build gpio server from source using go but i get a few errors with comand go build, i install goland to do that, any help?

http://github.com/gorilla/websocket src/github.com/gorilla/websocket/client.go:178: undefined: net.Dialer

http://github.com/kidoman/embd src/github.com/kidoman/embd/detect.go:58: undefined: strings.TrimSuffix

Hey @Carlos_Tavares can you give me more details about what platform you are compiling on and the steps you did to get to that error?

it´s beaglebone black with debian, i install goland to use GO, i make my gopath and inside mygopath i run “go get http://github.com//benjamind/gpio-json-server” after a few seconds i get this error

What version of go is that? I’ve only tested this on 1.4.1 which I compiled from source on my Raspberry Pi, though I have compiled the same dependencies on a Beaglebone Black before now as well (again 1.4.1).