Hi, I seem to have a problem connecting my 3D printer to my PC,

so, restarted my laptop, went to device manager and the COM port still has the exclamation mark and the info says “this device cannot start”…

Just out of curiosity, do you have the Arduino IDE installed? Sometimes installing that can help on Windows as it installs all needed drivers automatically.

@Ax_Smith-Laffin yes i do.

Unfortunately, that’s as much as I can help with this one, just stuff I’ve come across in the past. I run Linux most of the time, which supports IDE natively.

Creating the port yourself will never work. First off, delete that port you manually created.
If it’s a ‘real’ port, it will show back up on it’s own anyway.

Ok, deleted the port I made and still, when I connect my printer to both my desktop or laptop, still nothing pops up in device manager…:frowning:

Random question, have you tried a different USB Cable?

@Ax_Smith-Laffin yes. 3 different cables

Does anything pop up in devices & printers under your regular printers? You should get an unknown device showing up there.

Have to solve that issue first for a USB COM port to show up in the device manager.

Not sure what else to suggest for you to try… other than a different printer. :stuck_out_tongue:

Nope, nothing, I just think that it might be my motherboard on my printer, so I might just buy a new board and try that, or a raspberry pi 3.

Do any other USB devices work on that computer? Limit yourself to testing USB 2.0 devices for a more useful test.

Yes all other usb devices that I have tried, 3.0 and 2.0 have all worked on both computers.

could it be that my USB portion of my motherboard is fried? and i just need to buy a new motherboard?

could it be that my USB portion of my motherboard might possibly be fried? and i might just need to get a new motherboard?


Wait, actually I now don’t even think I have an Arduino Board… and I’ve been trying everything Arduino, drivers and all.

I think I might have marlin, because my Board is a Anet v1 control board.

@Jeff_Parish do you have any insight on this board or if I might just need to buy a new board?

@sp1redgryphon_97 I use a custom board for my printers. No insight on your board other than Anet is an Arduino based board. Marlin is firmware and not a type of chip.

Could be that your board USB port is fried.

Are you looking for a new Anet board or another type of board?

@Jeff_Parish right now if that is the case that my USB port is fried, I’ll be looking for a new anet board.