Hi, I seem to have a problem connecting my 3D printer to my PC,

3d-faq
3d-qa
3d-help
gplus
(sp1redgryphon 97) #1

Hi, I seem to have a problem connecting my 3D printer to my PC, a COM port is not showing up in my device manager but in other devices it has a unknown device with a exclamation mark on it. i think that is my printer but not entirely sure. I installed arduino on my pc and installed the COM drivers and other USB drivers that came with the installation but still no luck, whenever i connect my printer nothing happens on my pc, my slicing software doesn’t see it and it shows up as unknown device in device manager, so i’m thinking that i will have to install the correct drivers, but i don’t know where to get the drivers at. my firmware is Marlin v1 i think and the 3D Printer i have is a CTC DIY i3 Pro B.

(sp1redgryphon 97) #2

and my system is Windows 10 64 bit

(Jeff Parish) #3

Strange that you don’t see a Com port listing in your devices with an explanation point on it. maybe you have already tried the following but just in case… Try right clicking on the device with the explanation point on it and go to properties. Select update the drivers and allow searching the web. Wait for about 2 hours and there is a good chance your computer will find the right drivers and things should work. It may require two steps as first it will recognize your device but not the com port so you might need to do the same thing to the com port when it shows up.

(Mano Biletsky (Open MAKER)) #4

You probably need an atmega1284 or atmega2560 driver. They show up as acm0 or acm1 when connected and not as com1 etc.

(sp1redgryphon 97) #5

Ok, and could it possibly be that I need to update or install new firmware on my board?

(Kevin Danger Powers) #6

I don’t bother connecting my printer to my PC. Using a memory card works just fine and isn’t a pain in the ass.

(sp1redgryphon 97) #7

true, but i am trying to setup OctoPrint without a raspberry pi and just using a USB connection for right now until i get the money for a raspberry pi.

(Ax Smith-Laffin) #8

Grab the FTDI drivers from http://www.ftdichip.com/FTDrivers.htm

(sp1redgryphon 97) #9

ok, so i installed the drivers and they say there installed after the installation but nothing is showing up in my device manager.

(sp1redgryphon 97) #10

ok, now i restarted my PC and updated the driver and restarted my PC again after that and still, whenever i connect my Printer, nothing happens. but there is a USB Serial Port (COM5) in my device manager now.

(sp1redgryphon 97) #11

oh yeah and it (COM5), has a exclamation mark on it now.

(Daren Schwenke) #12

How old is your computer? Perhaps you have an actual physical COM port which is confusing you. If newer, try ‘Run as Administrator’ for all steps.

(Jeff Parish) #13

@sp1redgryphon_97 Almost there. Click on the COM5 USB serial port and go to properties and select update driver. Let the computer search the web. It might take awhile.

(sp1redgryphon 97) #14

@Jeff_Parish I did and it reverted back to Communication Port (COM5) so I had to manually update that with the right driver again so that did not work. Could it be because I possibly might need to Flash my board? And if so…How?

(Jeff Parish) #15

Reverted back to COM 5 from what? It should state whatever COM port gets assigned to your printer when you plug it in. Once it updates it does not matter what port number it gets.

Don’t know how you would flash your particular board. Typically I do it through the PC COM port which you can’t get it to recognize yet.

The fact that the computer now recognizes your printer is plugged in and assigns a COM port is good progress. Once you let the computer update the port and the splat disappears set your slicer or Octoprint to the assigned COM port number (use the right baud rate) and see if you can connect.

(sp1redgryphon 97) #16

@Jeff_Parish oh I don’t even think my computer is even recognizing that my printer is even plugged in… I created that communication port then updated the driver with “add legacy Hardware” option in the action tab of device manager.

(Jeff Parish) #17

Oh, then you are back at square one. I thought that plugging in your printer was creating the USB COM port. It should get automatically assigned and the number can change each time you do.

Not sure what drivers you need for your printer so that the PC recognizes it.

(sp1redgryphon 97) #18

@Jeff_Parish yep same problem I’m having, and sadly CTC has no support

(sp1redgryphon 97) #19

Now onto more promising matters… my laptop on the other hand did have a COM port pop up when I connected my printer, I think, because I didn’t install any drivers manually like I did on my desktop. But… the COM port is showing up as unknown device with an exclamation mark.

(sp1redgryphon 97) #20

ok, so i have now updated the driver on my laptop to Arduino Mega 2560 driver even though i think my board is Arduino Mega 1284. lets hope it works, restarting my laptop now.