Hi , I installed 3 times FastLEDv3.1.zip from here and I dont know why

Hi , I installed 3 times FastLEDv3.1.zip from here and I dont know why its still detecting another version.

#if FASTLED_VERSION < 3001000
#error “Requires FastLED 3.1 or later; check github for latest code.”

What version of arduino are you using? There was a change in a recent version that seems to have caused problems with one of the pragmats being used.

Arduino uno

Not the hardware, what version of the arduino ide did you install?

just remove version check or change #error to #warning; it seems as a bug in the latest arduino ide

Ok - found the problem. Arduino 1.6.6 runs gcc in a pass to build a set of dependencies before compiling - this appears to not include header files, so FastLED.h doesn’t get included, or parsed, and FASTED_VERSION never gets defined.

Changing the line to:

#if defined(FASTED_VERSION) && (FASTED_VERSION < 3001000)

will also fix the problem while retaining the version check.

Thank you for helping, I will try and I will reply.

What’s going to be a little bit trickier to fix/work around is why arduino 1.6.6 doesn’t appear to generate prototypes anymore for .ino files.

Ah - that problem (which I don’t think you’re hitting here) is https://github.com/arduino/arduino-builder/issues/68

I dont think clearly what i have to do.
Is that code i have to change ? #define FASTLED_VERSION 3001000
#warning FastLED version 3.001.000 (Not really a warning, just telling you here.)
Thank you