Hi, I have recently been trying to get an Arduino with a Protoneer shield

Hi, I have recently been trying to get an Arduino with a Protoneer shield to work without success, here is what I have done.
Loaded GRBL into my Arduino and checked it working with the serial port, no problems.
Started Chilipeppr and installed JSON server (several times) but still cannot connect, at the top right of Chilipeppr I see the notice “You must connect to your GRBL device using the GRBL buffer algorithm in this workspace. etc”
I also see “Serial Port JSON Server Disconnected” If I try to connect I have a dialog box popup saying “Serial port ajax error” followed by “Serial port ajax connection closed. readyState: 3”
Scanning for ports only results in “Found 0, Scanned 254” I am at a loss what to do next I have tried over and over again, I can only presume that JSON is not working but don’t know how to check for this. I am using Windows 10 x64 on a laptop but have not tried it on another machine yet. If anybody can help or point me in the right direction I would be eternally grateful.

Can you post a screenshot

Hi John, here is a screen shot of chilipeppr with some Gcode dropped in, I have tried everything I can think of to connect and don’t really know what to try next, but I am new to Chilipeppr.

What computer is your Serial Port JSON Server running on? What is the IP address of that computer? Or better said, are you running SPJS on localhost? If so just connect to localhost to get connected to SPJS.

Hi John, sorry for the delay answering, I am running it on a laptop with Windows 10 x64. ip is
Strangely I tried this on an old laptop running Windows 10 x32 and managed to get it to work, then coming back to my normal machine I got it to recognise the port and it showed and buffered the gcode but would not send it to the Arduino. Back to the old laptop and it would not work there so I don’t know what is going on!
Now all I get is a “Serial port ajax error” on both machines. I swapped the Arduino for another genuine one with the same result. Both Arduino are running GRBL fine so I don’t think it’s them, and seems to me that all is left is the JSON server I think I got the right one, it is 1.80 Windows x64. Device manager shows Arduino on com 6

OK John I think I have this worked out, maybe I did not understand it in the first place. I had installed JSON and closed down the black terminal window after installing it, thinking this should only need doing once, I find with a little experimenting that if I install every time and leave the black window open it connects perfectly every time, I only need to select grbl instead of default by the com port and check the box and it all works.
I have tried this on 2 windows 10 machines and it is the same on both, is this how it is supposed to be done ?
Many thanks for your help


Why don’t you watch the tutorial video on Youtube https://www.youtube.com/watch?v=mKLdgpz8gpQ

I have twice and very good it was too, but I did not realise that the JSON window had to be kept open, I thought once it was installed that was it, sorry for being so dim witted, I’ll blame it on the advancing years :slight_smile: