Hi, i am trying to get my Mac / chillipeppr / rpi3 / tinyg

Hi, i am trying to get my Mac / chillipeppr / rpi3 / tinyg - setup running but without success so far. serial-port-json-server-1.88_linux_arm is up and running and i can connect to it with chillippr but i always get a serial port system message saying that there is no port selected. I added a screenshot to better show what i am talking about. Any help is greatly appreciated. Cheers.

How recently did you pull your copy of SPJS 1.88? I had a similar issue with an initial beta build of 1.88, but it was later fixed (I was running SPJS Linux_x64).

I just tried my Pi, seems to be connecting (in my case to tinyG2)
Method
SSH into PI. CD to directory where I keep SPJS. Run "wget https://github.com/chilipeppr/serial-port-json-server/releases/download/v1.88/serial-port-json-server-1.88_linux_arm.tar.gz
“.
Run " tar -xf serial-port-json-server-1.88_linux_arm.tar.gz” to unpack the archive. CD into the unpacked archive. Run “./serial-port-json-server -v”.
I keep the Pi console window open to watch messaging.
I am NOT running SPJS as a daemon, so I need to keep console open anyway( this is my debug/test mode).

My installed SPJS has this look in ls -l : “8311512 Feb 6 19:19 serial-port-json-server”

PS This G+ interface not very friendly for this type of discussion, try https://groups.google.com/forum/#!forum/chilipeppr ?

Hey Carl. Thank you very much for taking the time to help me. I installed the latest 1.88 again but my problem is still the same despite the fact that SPJS seems to be running just fine. I’ll try the chilipeppr forum for some more questions. Cheers.

Just uncheck the TinyG and re-check it. It needs to be green to show it is the “default” port because CP can connect to secondary ports for controlling other things like lasers.