Hi guys, sorry to bother you again with another issue.

Hi guys, sorry to bother you again with another issue. I didn’t uses chili for a while as I was waiting for new bits, and today I went on for a new pcb with the 0.13 bits. I tested at a safety height and all was fine. I ran the probe test to set the initial z0 and was fine too, it nicely stopped at contact. Then I ran the full Autolevel probe, it started downing to z0, bit made contact and stopped. Since here all as expected, but then nothing else happens. No leveling up for next probing point at all.

On the console i get:

G0Z1.5
G0X0Y0
G0Z0.5
G38.2Z-0.5F5
G54 G17 G21 G90 G94 M0 M5 M9 T0 F5.]
G54 G17 G21 G90 G94 M0 M5 M9 T0 F5.]
G54 G17 G21 G90 G94 M0 M5 M9 T0 F5.]
G54 G17 G21 G90 G94 M0 M5 M9 T0 F5.]
G92Z0
G54 G17 G21 G90 G94 M0 M5 M9 T0 F5.]
G54 G17 G21 G90 G94 M0 M5 M9 T0 F5.]
G54 G17 G21 G90 G94 M0 M5 M9 T0 F5.]
G54 G17 G21 G90 G94 M0 M5 M9 T0 F5.]

and it keeps adding same line until I cancel autolevel…

I have been checking filters on probe and limit switches and all look good. I run it on Chrome, Win7 and just downloaded JSON 1.86, although I don’t believe it is the problem, as it runs the Gcode flawless. Any hint?

Another question. I am going to drill tiny tracks for my first time. On a 0.13 bit, 6000 rpm and 180mm feed seems reasonable?

Thanks for the great job

Hi Enric
I can see the same problem, but with GRBL.
Chilipeppr starts to check the first point. then after lowering the probe an finding the “zero” it stops. After twice pressing the Pause button , Chilipeppr moves to the next point and checks it, but without registering the new datas.
I hope, Chilipeppr will find the bug realy fast.
Regrads, Paul

On tinyg some people have reported similar symptoms with a touch plate, you could try reversing the wires from the pcb and the bit. I know that doesn’t sound like it will do anything, and it may not, but that was the solution for the touch plate.

Hi Ray
Thanks for response.
I did a test with your sugestion, but with no success.
Since this procedure was running fine during my last trial, a few weeks ago, it looks for me as a bug in Chilipeppr.
Regards, paul

Thanks for ruling that one out. I will leave further diagnosis to others more experienced in this area than myself. Screenshots or quick vid usually help.

I’m a TinyG guy and the probing and auto-level work flawlessly. I presume @enricodina that you are a Grbl user. I’ve heard a couple other Grbl users say the same thing. You could ping @Jarret_Luft and see if he has any ideas. Could somebody post a video of the problem?

Yes, im Grbl. Although i see most nice developement is being readied for tinyG and I might migrate soon.

I tried fliping wires as stated in some posts below, but no joy

Why is there an abandoned square bracket in the output? That makes me think the version of firmware you’re using changed the format and thus the parsing is getting messed up where the auto-level widget tries to interpret what’s going on with the probing. This is just a theory cuz I don’t know the nuances of Grbl, but I do know that Grbl not outputting JSON like TinyG does is part of the problem of working with Grbl.

@jlauer I am experiencing the same issue as the original poster, except that I am using TinyG. I was not having any issues with autoleveling as of February 5th, but today I have the same symptoms as above. If it is any help, I turned on the debugging output in Firefox, and received the following error:

To my inexperienced eyes, it appears that the THREE.js team may have updated something which causes Chilipeppr to crash. It may also be important to note that the probe location matrix disappears upon contact with the board.

Further research suggests that “THREE.Shape.Utils” has been renamed in recent versions to “THREE.ShapeUtils” which may be an issue, however, the commit which made this change was on October 15th, 2015, and I cannot find any commits which removed potential aliases to “THREE.ShapeUtils” with the name “THREE.Shape.Utils” so this does not explain why the issue has arisen so suddenly.

I just found this too. It looks like only in r74 which was released 20 hrs ago did they fully remove THREE.Shape.Utils as they seem to have done a layover for 1 version. I found the errors in the TinyG widget and am releasing shortly. @Jarret_Luft owns the Grbl auto-level widget so he would have to change it there.

Had to change line 703 from:
triangles = THREE.Shape.Utils.triangulateShape ( vertices, holes );
to:
triangles = THREE.ShapeUtils.triangulateShape ( vertices, holes );

Ok, TinyG Auto-Level widget just published. @Andy_Meyer can you test it?

@jlauer Chilipeppr is running flawlessly now, thank you! It’s probing like a champ.

I’m still having the same problem with GRBL.

@Anders_Nielsen in the upper right corner of chilipeppr there is a dropdown menu where you should set force refresh to true. This will make sure that the latest changes get loaded. Please let us know if this resolves your issue.

@Anders_Nielsen The change which was made to the TinyG workspace does not affect the GRBL workspace, the author of that workspace will have to update it before you will notice any changes.

Thanks to anyone who tinkered a solution. Will wait for mr Luft to have a bit of time

If Jarrett isn’t able to dive in and make the tweak, we could possibly move the Grbl workspace to Cloud9 and open up joint editing collaboration for these kinds of quick fixes. That it one gain we get out of cloud9 that we didn’t have with jsfiddle.

Done deal: http://raykholo.github.io/workspace-grbl/

Grbl workspace is now in Cloud9. Nothing else is changed though. So inside it still points to JSFiddles. A lot of those are the same as the TinyG widgets so you can replace the links to the raw github url’s (see chilipeppr/workspace-tinyg for these), but some widgets, namely auto-level, axes, and the grbl widget itself, are unique for the grbl workspace so it’ll be fixed before integrating the new version. Follow my video tutorial for moving a widget from JSFiddle to Github/Cloud9! Or if you want to fix the auto-level more quickly just fork it in JSFiddle and send us the new link when it’s ready.

You can fork my grbl workspace from here: https://github.com/raykholo/workspace-grbl

Congrats on reading this far, let me know if you need links/ clarification.