Hi folks, Just want to ask if anyone got this problem.

Hi folks,

Just want to ask if anyone got this problem.
When I run workspace from “http://chilipeppr.com/myworkspace” I get this green div with COM ports, as usual. But when I run the same workspace from Github Pages for ex.
http://myusername.github.io/myworkspace I don’t see COM ports at all.

Does anyone know how to fix this?

e004b70498f563a008ccbc03621bde0f.png

58ce1334bae046cccf25b8c27c70b667.png

It says you’re disconnected in the one screenshot, so that would be why you wouldn’t see COM ports at all. It would be easier if you were giving us full screenshots too because I want to know if you are using an HTTPS:// url or not because that’s a top candidate for errors.

Yes, the link with no working COM ports is with https:// .
Here is the link of workspace https://oltronic.github.io/cnc/
Any ideas how to solve this?

Take a look at your javascript console and you’ll probably see the error. You can’t connect to spjs via websocket without ssl if you’re on an ssl website.

Your workspace looks really cool. It may just be easier to host it as a workspace on http://chilipeppr.com if you want. Up to you though.

Yes mate, at the end it’s just easier to host it at chilipeppr. Any thoughts how to change 3D viewer background? I tried from widgets css, and also from fiddle. But with no success so far.

The 3D viewer is the most complex part of the app (after the Eagle BRD widget) so you are going down a very hard road there. However, with that said, changing the background in Three.js inside the 3D viewer is just set during the instantiation of the Three.js instance. Go search the Internet for how to set the clear color for Three.js.

Also, make sure you watch the 3 videos on the home page of http://chilipeppr.com to get a good feel for the structure of everything. It all starts to make tons of sense after you watch those videos.