Hi! First of all, sorry for my bad English.

3d-faq
3d-qa
3d-help
gplus
(Jasperi Kuikka) #1

Hi!

First of all, sorry for my bad English. Obviously I am not native English speaker but I hope the message is transmitted.

I have two issues with my Wanhao Duplicator i3 Plus printer:

  1. X-Axis end stop is triggered all the time no matter if it is pushed down or not. As you know it is located in the left side of x-axis. The x-axis does not go home as told but moved a few millimeters to right. I can manually force the print head to move left but it will crash to the carriage eventually. I solved the status of end stops by using M119 command and other switches worked as they should. It did not change the situation when I pushed the switch by finger.

  2. Extruder temperature is stuck at 210 °C. When I turn the printer on, the thermistor claims the temperature to be that 210 °C but I can clearly tell the heater block is not heated at all. If I set the temperature to for example 100 °C the temperature won’t decrease. If I set it greater than 210 the heater will start to heat the temperature. After a while a text appears to the screen saying there is error in temperature and the heater is turned of.

Things I have already done:

  • I checked all the wirings and connections in case of short circuit or bad connection but no luck there.
  • I suspected that the firmware was spoiled someway so I updated both firmwares (motherboard and LCD screen) but no changes to better
  • Switched the end stop switches with y-axis but the same symptoms occurred.
  • Thermistor changed with no influence.
  • Mother board changed couple of months ago. After that the printer worked fine.

Do you have any suggestions what to try next? If something was not clear I will try to explain it more precisely. Thanks in advance!

(Stephanie A) #2

Those are serious issues. For the endstop I would determine if the wiring is bad. Go right to the board and remove the old wire, and plug in wire to a good endstop from another axis.
If that does not work it might be firmware. You said you replaced the board before, but was it exactly the same? The firmware might not be for the right board or might be configured incorrectly. This would also explain the thermistor readings.
The thermistor could also be bad. It could be shorted, or the wrong one selected in the firmware.

(Jasperi Kuikka) #3

@Stephanie_A Thanks for the answer. I already checked the wiring but maybe it is a good idea to check it one more time. I also tried to change the switches with y-axis but the issue remained. The x-axis switch works good in y-axis so I assume the switches are working properly.

I also updated the firmware but both issues remained. Yes the motherboard was changed and after that it worked as it should for a while (many months). So I think the mother board is the correct one.

The thermistor was replaced also after the issue came out but it did not change the situation. I check the selected firmware once more.

(Stephanie A) #4

Ok, so there are only 2 things left, firmware and board. If the issue is firmware then it could be how the endstop is configured. There is active high, and active low, and pullup enabled or not.

If you have a multimeter you can check the pins. Measure the voltage on both pins when the switch is pressed and not pressed. You should see the voltage change from 0v to 3-5v or from 3-5v to 0v.
If the voltage doesn’t change then either a pullup is enabled when it shouldn’t be, or the controller is damaged.

(Tinkering On Steroids) #5

Could the temperature reading be a missmatch between Thermistor and Thermocouple?

(Jasperi Kuikka) #6

@Stephanie_A I checked the voltage readings and I was only able to have some readings in mV which is obviously too little. I am suspecting the board because the firmware is updated but I will try to configure it again. Lets see what happens. I changed the PARKING_EXTRUDER_SOLENOIDS_PINS_ACTIVE to HIGH, but it did not help. Where I can find the pullup settings?

(Jasperi Kuikka) #7

@Tinkering_On_Steroid Could you explains more precisely? I am willing to test it if its possible. I checked the thermistor resistance which was 101kohm and it corresponds with the firmware.

(Tinkering On Steroids) #8

There are two different types of tempereture sensors:

  1. Thermistors (THERMally-sensitive resISTOR) which is basically a resistor that changes its resistance according to the temperture. Can be directly connected to an analog input of a control board does not require additional circuit.
    https://en.wikipedia.org/wiki/Thermistor

  2. Thermocouples generate tiny amounts of electronic energy out of temperature, needs to be ampliefied, requires amplifier circuitry (implemented in the mainboard or attached as breakout pcb)
    https://en.wikipedia.org/wiki/Thermocouple

Let’s asume your sensor is a Termistor and was on the original board connected to a usual analog input and you now have a more advanced board that expects a connected Thermocouple and only provides connectivity to a amplifier => issue

…or the other way around:

Let’s asume your sensor is a Thermocouple and was on the original board connected to a thermocouple ampliefier and your new board only provides connectivity to a usual analog input => issue

(Jasperi Kuikka) #9

@Tinkering_On_Steroid Thanks for the explanation! I think the sensor type is correct for the motherboard because both are original spare parts from the manufacturer. But good to know anyway :slight_smile:

(Stephanie A) #10

What firmware does it use? I’m assuming Marlin? Can you provide a link to the replacement board that you bought?

(Jasperi Kuikka) #11

@Stephanie_A This is the board: https://www.3dprima.com/accessories/spare-parts/wanhao-i3-plus/wanhao-main-board-to-duplicator-i3-plus/a-22090/

And the firmware is this one version 3.0.1: https://github.com/andrivet/ADVi3pp-Marlin/releases

Do you see any issues?

(Jasperi Kuikka) #12

Just to let you all know. The problem was because of motherboard. What was causing that is still a mystery but we are having new motherboard from the dealer soon. Let’s hope everything works as planned. :slight_smile:
Thanks for the effort and time you spent to this matter. I really appreciate it!