Hi everyone. Thirst thing I wanted to thank everyone how created and participated in

Hi everyone. Thirst thing I wanted to thank everyone how created and participated in the development of chilipeppr. I finally got a small CNC specifically for making PCB. It is working fine so far and below there is a photo of my first few PCBs. As you can probably see I’m having a problem when it cuts the outline of the board. It gets to the top right corner and decides to come across diagonally cutting straight through the traces. Has anyone got any idea of what I’m doing wrong. When I run the simulation it doesn’t do that. Thanks a lot for any hepl

Please share more details about your machine, controller type, did you generating the gcode from Chilipeppr? Or just imported it?
Most probably this is a hardware issue, it seems that your machine is skipping while moving to the left when milling in full board depth.
Try cutting outline in 2 or 4 steps.
It’s clear that your tools are dull or you are not using the right speed & feed rates.

@andrea_buono ​​ Does the outline look OK in the 3D viewer? Maybe you could post a screenshot or share gcode file?
I had similar problem with outline path in the past after dragging BRD file onto Chilipeppr (there was a post about it) but all works fine now.

I don’t think this is a loosing steps related issue, as milled traces are not distorted and the outline line is straight, just wrong direction = improper coordinates in the gcode file.

EDIT:
Here is my post related to the same issue: https://plus.google.com/+SebastianSzafran/posts/jaTusRkRFZu and recreating (saving a copy) of the file in Eagle solved the problem for me.

Thanks for the reply. I ran a few more tests changing different settings but no difference. I however managed to solve the problem by using the milling layer in eagle for the outline. This worked with no problems. Might be a coincidence but not sure. I’ll run a few more tests and try to find out what the issue is.

Do you create the gcode in Chilipeppr directly by dragging the BRD file (this is my guess)?
How does the outline path look in the 3d viewer widget?
Are you using the /tinyg or other workspace?
Sharing more information allows to see the issue clearly and gives a chance to provide better support, also helps other members of the community.

@sszafran That issue with board dimensions was solved, Eagle saves dimensions as individual lines without caring about their order, I solve that by sorting the wires in the right order before rending the board or generating any Gcode.
@andrea_buono if board dimensions are not rendered correctly in 3D viewer, please open an issue on github and I’ll try to find a solution.

Sorry about that. Yes I’m dragging the BRD file into CP. My board is a grbl controller. The CNC machine is a Eleksmill I bought on Aliexpress.

missing/deleted image from Google+

So i did some more tests but apparently it is still not working. It just decides to randomly cut trough the pcb. I have attached the g code that was generated by CP. The rendering is perfect but when it runs it goes on a different path. I will also ad a video to better demonstrate.
https://drive.google.com/open?id=0B2cIXz6sDK37bmhvMEhURDdkLUE

The file is empty

Sorry I just updated it. Should be ok now

This is a short video showing what happens

Gcode look good in 3D Viewer, I suspect that your controller is not interpreting curves correctly, can you try board dimensions without curves?

Yeah that looks like a g2/g3 arc issue.

I recall there was some limitation in GRBL in line length or number of digits, but I don’t remember what it is exactly.

Also, I noticed that some small numbers are in scientific format like the following line:
G3 X2.8398 Y-0.5 I3.3398000000000003 J4.440892098500626e-16

I don’t know if this is considered a valid gcode!

Those numbers are so long that I have heard folks have problems. I tend to go max 3 digits on decimals. That’s likely the problem.

I tried straight lines in the past and it also had problems some times.
Do I get such high decimal places because of the grid size in eagle or am I doing something else wrong?

The widget code needs to just limit the decimal places as Javascript handles those decimals fine, but Grbl does not.

I’ll fix that shortly.

Nice. Something from me.
missing/deleted image from Google+

My machine .
missing/deleted image from Google+