Hi everyone, The last few weeks I've been experimenting with LED Strips and different

fastled-support
gplus
(Jozef SnetMar) #1

Hi everyone, The last few weeks I’ve been experimenting with LED Strips and different libraries but still struggle with FASTLED. My setup Teensy 3.2 72/96MHz, Arduino IDE 1.8.8, OctoWS2811, Adafruit NEOPIXEL both latest version from GIHub. 1 LED strip WS2813 (120 Pixels). The demo examples provided by OctoWS8211 and Adafruit NEOPIXEL work well with 120 pixels. FASTLed on the otherhand above 60 pixels I get strange effects or nothing at all. I use RGBSetDemo.ino as test example. I tried other examples and once above 60 Pixels FASTLed has problems. I tweaked the same example using Ada, Octo or FASTLed and Octo everything works well. Has any one an idea what’s causing this???

Update: Hardware : Teensy 3.2 Board, OctoWS8211 just to level out 3.3V-5Volt and WS8213 Strip 120 Leds connected to pin 2. Software : Arduino IDE 1.8.8, FASTLED library 3.2.4, Adafruit neopixel 1.1.8 and octows8211 1.4.0

(Jeremy Spencer) #2

I would try an older version of the FastLED library, 3.1 is a good start

(Will Tatam) #3

Do you actually have the hardware for the octows2811? I didn’t think you could use the neopixel library with that board.

Please supply full code example and notes on how you have things connected up

(Daniel Garcia) #4

It is possible you are running into timing problems either caused by interrupts - https://github.com/FastLED/FastLED/wiki/Interrupt-problems - less likely, but also try setting the led type to WS2812 - FastLED uses different timings for the different ws* led types, but the manufacturers aren’t always good about the timings they use.

(My guess is interrupts though - WS2813’s have a long reset time to allow for long interrupts - but I haven’t had a chance to update the library for that yet - which means on an interrupt the library may believe (erroneously with the WS2813) that it needs to restart the frame)

(Daniel Garcia) #5

@Will_Tatam The OctoWS2811 library does not require the OctoWS2811 board.

(Jozef SnetMar) #6

@Jeremy_Spencer Will try older version and give feedback.

(Jozef SnetMar) #7

@Daniel_Garcia I tried ws2812 led type. Works well with Ada, Octo and combo Octo/Fastled libraries. Use of fastled only not always only if <= 60 Leds. I don’t have the skills to figure what’s causing the problem.

(Will Tatam) #8

What are you using for power?

(Jozef SnetMar) #9

5v/60A…is overkill for 1 strip now. But if all works well with NEO and Octo…it’s not the power.

(Jeremy Spencer) #10

@Jozef_SnetMar Try defining the leds as SK6812, adafruit randomly use WS2812 and SK6812 LEDs in their strips and the timimgs are slightly different. This doesn’t matter to the adafruit library as it is so slow, but FastLED is fast and pushes chipsets to the maximum.

(Jozef SnetMar) #11

Tried all the different libraries. Above 64 leds FASTled acts weird in the teensy. Only solution #define FASTLED_ALLOW_INTERRUPTS 0 This works fine. Still needs further testing with the Audio library for my project. Don’t know how this will affect the interrupts.

(Daniel Garcia) #12

one of the things that will be coming with the rgbw/16-bit change is the also the ability to more easily tweak the interrupt buffer timings - i really cant wait to have the time to get the to a point of first public release/use