Hi everyone. I'm new to laser engraving so I'll try to be brief.

Hi everyone. I’m new to laser engraving so I’ll try to be brief.

I’m having some issues. I purchased a 50cm x 60cm 3000mW engraver on eBay. It’s awesome and works really well on the Windows BenBox software on Windows 7(I have a realllllyyy old laptop I installed windows 7 on just for this) and have engraved entire end tables and nightstands already with crystal clear precision(has new stepper motor drivers for cleaner signals and a few modifications to the actual rails for smoother rolling)…

I’m trying to get it to work on my Linux operating systems…
I love the way this LaserWeb 4 software looks and is way cleaner than the BenBox software and T2Laser just doesn’t look good and doesn’t work in the trial version I’ve tried anyways.
It seems us linux users are left in the wind in the software category for amateur laser engraving.

When I use LaserWeb 4, it says :

Machine connected
benbox laser 3.1© mul 2015.06.06
unknow M115
unknow M115
No supported firmware detected. Closing port /dev/ttyUSB0
Machine disconnected

Then it disconnects. It does this every single time. I have not been able to get it to work on here… I’ve used a little Neje laser engraver in the past on my linux computers and they worked fine with 3rd party software.

I don’t know what I’m doing wrong or what I need to do. I’ve tried everything I can think of. The documentation and wiki is confusing. I don’t understand any of it and it is hardly navigational in my opinion so I can’t even troubleshoot it myself.
I would really appreciate any help I can get. Thank you everyone!


Read this > https://github.com/LaserWeb/LaserWeb4/wiki/2.1-Initial-Configuration-GRBL-1.1

Okay… oh boy… is there a video or something I can watch as a hands on kind of thing. I don’t want to break this thing considering I have no idea what I’m doing to begin with.

I appreciate that super fast response, too… Thank you

I suggest you ask in this other community if no one answer here. Or search YouTube for your type of machine and grbl firmware

Alright. Thank you for that.

You have to flash grbl to the PCB, adjust settings and start to engrave. There is a huge difference between benbox software and laserweb in possibilities.

I’ve read the possibilities. I’m going to work on it later today and see where I get. Thank you.

okay. I got the Arduino IDE and GRBL source files all good to go. Question is… It keeps referencing Arduino Uno on the instructions from GRBL but I have a NANO DCCDuino(Just a cheaper clone of the nano arduino)… Do I need to make any changes before I compile and upload the code??


Apparently the latest IDE does not have all those options listed in that guide page… I don’t get the option of old bootloader… So I’m just going to hope I can flash it successfully

Okay so I was surfing duckduckgo and found someone who compiled their own code using ATmega328P on board NANO successfully with this clone board. Now I can’t find anyone who has successfully put GRBL 1.1 on this specific board… I have no idea why it is so scarce to find this information. I never have this much trouble.

Alright. Flashing it over worked and it sorta works with laserweb now… Doesn’t burn full images ;/

In laserweb you have to set to grbl profile.
Also, you have to set some parameters in grbl, from a terminal connected to the board (you can use arduine ide terminal)

okay thank you
I’ll try and figure this out

Generic GRBL profile is selected but I have no idea how to set parameters

Default parameters to generated gcode operations are set when choosing and aplying the profile. Make sure your S values on the firmware are modes per my link before, specially laser mode

I went and set the default parameters using T2Laser Trial and I’m not sure if it did anything yet. I’ll wait for this engraving to finish

okay I’m getting it now. This is starting to come together. The s values were definitely off and I used the laserweb console to set them and now my laser is running like it is supposed to. The burns are coming out much better.
Thanks for bearing with me, everyone. I really do appreciate the help.
It’s been a long time since I’ve used anything arduino so I’ve been out of the loop… Probably wouldn’t sound good if I said I’m a software engineer for an undisclosed agency either lol

Man this is going to take forever. It is now acting crazy when engraving with the lazer. I added the parameters given in that laserweb link at the first comment… and now the laser is grinding gears to reach a negative y and x… I don’t get it.