Hi everyone, I have been using Chilipeppr for some time now and most of

gplus
(John Hornsby-Hunt) #1

Hi everyone,
I have been using Chilipeppr for some time now and most of the time it works fine. I’ve just changed the machine that I run Chilipeppr on from an old Windows XP machine to a Windows 10 laptop and a few things now won’t work. (When I say won’t work, I mean only on the PC screen, not an actual CNC machine).
Firstly, when I run a ‘Demo’ the image of the tool head moves according to the toolpath and graphically traces the route correctly. When I kick off the job for real, the steppers fire up fine and move according to the job, but no movement is displayed on the screen. Also, no position measurements are shown in the X, Y, Z dimensions boxes, they all show as 0.00.
The other thing that fails to work is manually moving the X, Y, Z positions by using the ‘Move by’ feature. Clicking on any of the movement amounts will move the X Y or Z stepper motor but not the indicator that shows the Tool Head position or the amount of movement moved. It’s like the steppers are being controlled OK but no screen updates are happening.
Finally, there is a RED warning message about ‘connecting to the GRBL device’ that I don’t understand. I’m connected ok via the Serial Port Json Server tool, I think.
Any help would be good – thanks
First Image: Chilipeppr_on_WIN_XP
Second Image: Chilipeppr_on_WIN_10

(JOHN LAUER) #2

Looks like you aren’t getting any info back from your Grbl device. Are you sure you’re connected with Grbl buffer chosen in serial port list?

(John Hornsby-Hunt) #3

Thanks John for the reminder – that was the issue – the serial port list not configured properly. Great stuff, thanks once again.