Hi everyone hopefully you can help I have a laser cutter that I'm using

smoothie-help
gplus
(Glen Scott) #1

Hi everyone hopefully you can help I have a laser cutter that I’m using with laserweb4 I have cut a few things out with it already however it started to have an issue where when I jog the y axis one of the paired motors only rotates in one direction. Again I have used it before without issue this just started happening today and I have no clue why any help is greatly appreciated

0 Likes

(Arthur Wolf) #2

This is most often caused by only 3 of the 4 wires connecting the stepper coils to the driver’s fets being conductive/connected. This can be caused by a faulty connector/crimping, on the motor or driver side, by a broken/cut wire inside it’s insulation, or more rarely by a broken motor coil or broken driver fet. If only 3 of the 4 are connected, the symptom is typically what you describe ( movement in only one direction ). This is also often ( not always or not always easy to detect ) associated with less smooth movement and/or less strong rotation of the stepper, and/or clunky/weird rotation. Check everything, re-do your crimps, test continuity with a meter.

0 Likes

(Glen Scott) #3

@Arthur_Wolf I thought that the wiring was the issue too but I switched the motors and the problem moved with it so I think it’s the driver but I’m not sure how exactly because it worked a few times even after it showed this problem

0 Likes

(Arthur Wolf) #4

Ah. So just to be clear, you mean that you tried a different motor on the same driver, and the driver exhibits the same problem with the new motor correct ?
I’m going to assume you tried the first motor on another driver and it worked fine there.

If this is the case, then I my main suspect would be that the fet for that coil inside your driver is broken ( EMI, ESD, a short, or moving the motor by hand which feeds potentially dangerous voltages back into the driver, are all known to have caused this in rare instances )

Some other much less likely suspects you can check for :

  • Get a fresh SD card, format it, and put a fresh ( latest ) example config file, completely unmodified, and ( latest ) firmware on it, and try moving the axis with this new setup ( backup your original config obviously )
  • Use a meter to test whether the dir pin ( measured at it’s breakout pins ) gets toggled by your Gcode the way you’d expect it to ( moving from 3.3v to 0v and vice-versa )

Make sure you read https://github.com/Smoothieware/Smoothieware/blob/edge/upgrade-notes.md in case something there would be relevant.

Just in case, test this with pronterface instead of laserweb, it’s more stable/has better smoothie support, and doesn’t hide information sent by smoothie the way laserweb does. I can’t see how this could be related, but I’ve had cases in the past where it didn’t seem related but testing pronterface turned up something so I recommend it.

If the driver is dead, you have options. If you feel comfortable doing SMT soldering ( it’s easier than it seems, most users are surprised by this when they try ), you can just try replacing the driver.
Or, possibly easier/less expensive, buy a TB6600 ( very cheap ) and wire this as an external driver in place of the on-board driver, and connect the motor to it.

These instructions will work with TB6600 : http://smoothieware.org/general-appendixes#external-stepper-drivers

Whatever you attempt or do not attempt, please provide details on what you attempted/did not attempt among the possible debugging methods/fixes mentioned above.

1 Like